PAT甲级——1146 Topological Order (25分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
第一次写拓扑序列的题目:
柳婼的解法,带我自己的注解的版本~
#include <iostream>
#include <vector>
using namespace std;
int main() {
int n,m,k,a,b,in[1010],flag = 0;
vector<int> v[1010]; //定义二维数组v[1010][]
scanf("%d %d", &n, &m);
for(int i = 0; i < m; i++) //m 行边关系
{
scanf("%d %d",&a ,&b); //使用scanf存储边关系
v[a].push_back(b); //将便关系写入vector数组v[1010][]中
in[b]++; //入度数组加1
}
scanf("%d",&k); //接下来是k个拓扑序列
for(int i= 0;i < k; i++)
{
int judge = 1; //首先预设是正确的序列
vector<int> tin(in, in+n+1); //使用vector tin 复制入度序列 in[]
for(int j = 0;j < n;j++) //
{
scanf("%d", &a); //输入需要测试的顶点
if (tin[a] != 0) judge = 0; //如果入度不为0 ,则为假
for (int it : v[a]) tin[it]--; //将该点对应的入度减去1 ;其实是遍历v[a][]这一行的序列
}
if (judge == 1) continue;
printf("%s%d", flag == 1 ? " ": "", i);
flag = 1;
}
return 0;
}
上一篇: 6-10 阶乘计算升级版 (20分)
下一篇: 实验7-2-9 螺旋方阵 (20分)
推荐阅读
-
PAT (Advanced Level) Practice 1146 Topological Order (25分) (拓扑序列的判断)
-
PAT甲级--1146 Topological Order(25 分)【判断是否为拓扑序列】
-
1146 Topological Order (25分)
-
1146 Topological Order (25分)
-
1146 Topological Order (25分)
-
【PAT甲级A1146】Topological Order (25分)(c++)
-
1146 Topological Order (25分)
-
PAT甲级A1146 Topological Order(25 分)
-
PAT甲级1146 Topological Order (25分) 拓扑排序
-
PAT 1146 Topological Order(25 分)