欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

【PAT甲级A1146】Topological Order (25分)(c++)

程序员文章站 2022-06-07 13:13:26
...

1146 Topological Order (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

【PAT甲级A1146】Topological Order (25分)(c++)

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题意:

根据所给有向无环图,判断是否是正确的拓扑顺序输出。

思路:

回顾有向无环图的拓扑顺序输出,是记录每个点的入度,将入度为零的结点放入队列,然后从队列中输出时,将其子结点的入度-1,如有入度为零的结点那么继续放入队列,直到队列为空。那么这题一样,根据所给图,记录每个点的入度,顺序读入所给数列,判断其入度是否为零,并将其子结点入度-1,若不为零,那么这个顺序是错误的。

参考代码:

#include <cstdio>
#include <algorithm>
#include <vector>

using namespace std;
const int maxn = 1010;
vector<int> G[maxn], indegree(maxn), v;

int main() {
    int n, m, k, a, b;
    scanf("%d%d", &n, &m);
    for (int i = 0; i < m; i++) {
        scanf("%d%d", &a, &b);
        G[a].push_back(b);
        indegree[b]++;
    }
    scanf("%d", &k);
    for (int i = 0; i < k; i++) {
        bool flag = 0;
        vector<int> ind = indegree;
        for (int j = 0; j < n; j++) {
            scanf("%d", &a);
            if (ind[a] != 0)flag = 1;
            for (int t = 0; t < G[a].size(); t++)
                ind[G[a][t]]--;
        }
        if (flag)v.push_back(i);
    }
    for (int i = 0; i < v.size(); i++) {
        if (i != 0)printf(" ");
        printf("%d", v[i]);
    }
    return 0;
}

如有错误,欢迎指正

相关标签: pat 数据结构