欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1146 Topological Order (25分)

程序员文章站 2022-06-07 14:41:49
...

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

1146 Topological Order (25分)

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

编译器 (31)--C++

#include <iostream>
#include <stdio.h>
#include <vector>
using namespace std;

int n,m;
int num=0;

int a[10001];
int b[10001];
int c[10001];
int d[10001];


void cal(int index)
{
    for(int j=0; j<n; j++)
    {
        int p;
        scanf("%d",&p);
        b[p]=j;
    }
    for(int i=0;i<m;i++)
    {
        if(b[a[i]]>b[c[i]]){
            d[num]=index;
            num++;
            break;
        }
    }

}

int main()
{

    scanf("%d %d",&n,&m);
    for(int i=0; i<m; i++)
    {
        int p,q;
        scanf("%d %d",&p,&q);
        a[i]=p;
        c[i]=q;
    }
    int k;
    scanf("%d",&k);
    for(int i=0; i<k; i++)
    {
        cal(i);
    }

    for(int i=0;i<num;i++)
    {
        if(i==0)printf("%d",d[i]);
        else printf(" %d",d[i]);
    }
    printf("\n");

    return 0;
}

 

相关标签: PAT笔记总结 PAT