1146 Topological Order (25分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
编译器 (31)--C++
#include <iostream>
#include <stdio.h>
#include <vector>
using namespace std;
int n,m;
int num=0;
int a[10001];
int b[10001];
int c[10001];
int d[10001];
void cal(int index)
{
for(int j=0; j<n; j++)
{
int p;
scanf("%d",&p);
b[p]=j;
}
for(int i=0;i<m;i++)
{
if(b[a[i]]>b[c[i]]){
d[num]=index;
num++;
break;
}
}
}
int main()
{
scanf("%d %d",&n,&m);
for(int i=0; i<m; i++)
{
int p,q;
scanf("%d %d",&p,&q);
a[i]=p;
c[i]=q;
}
int k;
scanf("%d",&k);
for(int i=0; i<k; i++)
{
cal(i);
}
for(int i=0;i<num;i++)
{
if(i==0)printf("%d",d[i]);
else printf(" %d",d[i]);
}
printf("\n");
return 0;
}
推荐阅读
-
PAT (Advanced Level) Practice 1146 Topological Order (25分) (拓扑序列的判断)
-
PAT甲级--1146 Topological Order(25 分)【判断是否为拓扑序列】
-
1146 Topological Order (25分)
-
1146 Topological Order (25分)
-
1146 Topological Order (25分)
-
PTA练习题6-1 Is Topological Order (25 分)
-
【PAT甲级A1146】Topological Order (25分)(c++)
-
thinkphp视图模型查询提示ERR: 1146:Table 'db.pr_order_view' doesn't e_PHP
-
thinkphp视图模型查询提示ERR: 1146:Table 'db.pr_order_view' doesn't e_PHP
-
thinkphp视图模型查询提示ERR: 1146:Table 'db.pr_order_view' doesn't exist的解决方法,vieworder