1146 Topological Order (25分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
用邻接矩阵存储的图竟然可以过。将拓扑排序稍微改变了一下。
#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int g[1001][1001];
int INF=0x3fffffff;
int inDegree[1001],visit[1001],d[1001];
int sum,n;
bool topologicalSort(int a[])
{
int j,i,flag=1;
sum=0;
for(i=1; i<=n; i++)
{
if(visit[a[i]]==0&&inDegree[a[i]]==0)
{
visit[a[i]]=1;
for(j=1; j<=n; j++)
{
if(g[a[i]][j]!=INF)
inDegree[j]--;
}
}
else
{
flag=0;
break;
}
}
if(flag==1)return true;
else return false;
}
int main()
{
int m,i,j,k,b[110],x,y,a[1001],p=0;
scanf("%d %d",&n,&m);
fill(g[0],g[0]+1001*1001,INF);
memset(d,0,sizeof(d));
for(i=1; i<=m; i++)
{
scanf("%d %d",&x,&y);
g[x][y]=1;
d[y]++;
}
scanf("%d",&k);
for(j=0; j<k; j++)
{
for(i=1; i<=n; i++)scanf("%d",&a[i]);
for(i=1; i<=n; i++)inDegree[i]=d[i];
memset(visit,0,sizeof(visit));
if(topologicalSort(a)==false)b[p++]=j;
}
for(i=0; i<p-1; i++)
printf("%d ",b[i]);
printf("%d\n",b[p-1]);
return 0;
}
上一篇: 利用google map展示酒店所在位置
下一篇: JAVA两种常用排序方法
推荐阅读
-
PAT (Advanced Level) Practice 1146 Topological Order (25分) (拓扑序列的判断)
-
PAT甲级--1146 Topological Order(25 分)【判断是否为拓扑序列】
-
1146 Topological Order (25分)
-
1146 Topological Order (25分)
-
1146 Topological Order (25分)
-
PTA练习题6-1 Is Topological Order (25 分)
-
【PAT甲级A1146】Topological Order (25分)(c++)
-
thinkphp视图模型查询提示ERR: 1146:Table 'db.pr_order_view' doesn't e_PHP
-
thinkphp视图模型查询提示ERR: 1146:Table 'db.pr_order_view' doesn't e_PHP
-
thinkphp视图模型查询提示ERR: 1146:Table 'db.pr_order_view' doesn't exist的解决方法,vieworder