欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

SDUT-3340 数据结构实验之二叉树一:树的同构

程序员文章站 2022-05-06 22:45:53
...

数据结构实验之二叉树一:树的同构

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

给定两棵树T1和T2。如果T1可以通过若干次左右孩子互换就变成T2,则我们称两棵树是“同构”的。例如图1给出的两棵树就是同构的,因为我们把其中一棵树的结点A、B、G的左右孩子互换后,就得到另外一棵树。而图2就不是同构的。


SDUT-3340 数据结构实验之二叉树一:树的同构

图1

 

SDUT-3340 数据结构实验之二叉树一:树的同构

图2

现给定两棵树,请你判断它们是否是同构的。

Input

 输入数据包含多组,每组数据给出2棵二叉树的信息。对于每棵树,首先在一行中给出一个非负整数N (10),即该树的结点数(此时假设结点从0N−1编号);随后N行,第i行对应编号第i个结点,给出该结点中存储的1个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出”-”。给出的数据间用一个空格分隔。
注意:题目保证每个结点中存储的字母是不同的。

Output

 如果两棵树是同构的,输出“Yes”,否则输出“No”。

Example Input

8
A 1 2
B 3 4
C 5 -
D - -
E 6 -
G 7 -
F - -
H - -
8
G - 4
B 7 6
F - -
A 5 1
H - -
C 0 -
D - -
E 2 -

Example Output

Yes

Hint

测试数据对应图1

#include <iostream>
#include <cstring>
using namespace std;
struct tree
{
    char data;
    tree*left;
    tree*right;
};
struct node
{
    int l,r;
    char s;
}a[15];
tree*creat(int k)
{
    tree*root;
    root=new tree;
    root->data=a[k].s;
    root->left=root->right=NULL;
    if(a[k].l!=-1)
    {
        root->left=creat(a[k].l);
    }
    if(a[k].r!=-1)
    {
        root->right=creat(a[k].r);
    }
    return root;
}
tree*build(int n)
{
    int j;
    bool v[15];
    memset(v,0,sizeof(v));
    for(int i=0;i<n;i++)
    {
        char s1,s2,s3;
        cin>>s1>>s2>>s3;
        a[i].s=s1;
        if(s2=='-')
        {
            a[i].l=-1;
        }
        else
        {
            a[i].l=s2-'0';
            v[a[i].l]=true;
        }
         if(s3=='-')
        {
            a[i].r=-1;
        }
        else
        {
            a[i].r=s3-'0';
            v[a[i].r]=true;
        }
    }
    if(n!=0)
    {for(j=0;j<n;j++)
    {
        if(!v[j])
        {
            break;
        }
    }
    }
    tree*root=creat(j);
    return root;
}
int judge(tree*root1,tree*root2)
{
    if(!root1&&!root2)
        return 1;
    if(root1&&root2)
    {
        if(root1->data==root2->data)
            if((judge(root1->left,root2->left)&&judge(root1->right,root2->right))||(judge(root1->left,root2->right)&&judge(root1->right,root2->left)))
            return 1;
    }
        return 0;
}
int main()
{
    int n1,n2;
    while(cin>>n1)
    {
        tree*root1,*root2;
        root1=build(n1);
        cin>>n2;
        root2=build(n2);
        if(judge(root1,root2))
            cout<<"Yes\n";
        else
            cout<<"No\n";
    }
    return 0;
}