欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1270: 折线分割平面

程序员文章站 2024-03-24 15:53:10
...

明若清溪天下绝歌 缱绻成说,不知该在哪处着墨;一生情深怎奈何世事 徒留斑驳,只一念痴恋成奢。

题目描述

我们看到过很多直线分割平面的题目,今天的这个题目稍微有些变化,我们要求的是n条折线分割平面的最大数目。比如,一条折线可以将平面分成两部分,两条折线最多可以将平面分成7部分,具体如下所示。

1270: 折线分割平面

 

输入

输入数据的第一行是一个整数C,表示测试实例的个数,然后是C 行数据,每行包含一个整数n(0<n<=10000),表示折线的数量。

 

输出

对于每个测试实例,请输出平面的最大分割数,每个实例的输出占一行。

 

样例输入

复制样例数据

2
1
2

样例输出

2
7
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctime>
#include <cctype>
#include <bitset>
#include <utility>
#include <sstream>
#include <complex>
#include <iomanip>
#define inf 0x3f3f3f3f
typedef long long ll;
using namespace std;
int C,n;
ll s[10010];
int main()
{
    s[1]=2;
    for(int i=2; i<=10000; i++)
        s[i]=4*i+s[i-1]-3;
    scanf("%d",&C);
    while(C--)
    {
        scanf("%d",&n);
        printf("%lld\n",s[n]);
    }
    return 0;
}