HDU GCC(HDU 3123)解题报告
/*Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2646 Accepted Submission(s): 810
Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.
Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
Sample Input
1
10 861017
Sample Output
593846
*/
[html]
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
char n[1010];
__int64 m;
int main()
{
__int64 num,sum=0;
int i,T,m,k;
scanf("%d",&T);
while(T--)
{
scanf("%s%d",n,&m);
if(strlen(n)>=7)
k=m;
else
k=atoi(n);
num=1,sum=1;
for(i=1;i<=k;i++)
{
num=(num*i)%m;
sum=(sum+num)%m;
}
printf("%I64d\n",sum%m);
}
return 0;
}
作者:xieqinghuang
推荐阅读
-
HDU GCC(HDU 3123)解题报告
-
HDU 6205 card card card 解题思路【最长非零子序列】
-
hdu2100Lovekey解题报告---26进制高精度加法
-
hdu1584蜘蛛牌解题报告---搜索(深搜 & 回溯)
-
hdu2544最短路解题报告---SPFA算法
-
hdu1394Minimum Inversion Number解题报告---线段树(单点插值 & 区间逆序数求和)
-
hdu2058The sum problem解题报告---等差数列的和(数论)
-
hdu2086A1 = ?解题报告---推导求通项
-
hdu2079选课时间解题报告---母函数/生成函数(组合数学)
-
HDU GCC(HDU 3123)解题报告