hdu1394Minimum Inversion Number解题报告---线段树(单点插值 & 区间逆序数求和)
Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25219 Accepted Submission(s): 14878
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
题意:
给你一个有0--n-1数字组成的序列,然后进行这样的操作,每次将最前面一个元素放到最后面去会得到一个序列,那么这样就形成了n个序列,那么每个序列都有一个逆序数,找出其中最小的一个输出!
线段树求逆序数:
把树的叶子节点作为每个数的对应位置
单点插值到第i个数时,我们需要求出前i次插入的数中有多少个比vv[i]大,
即去寻找已经插入的数中比vv[i]大的数的个数 即查询叶子节点vv[i]到n的数的个数把每个vv[i]放到最后的逆序数为sum += n - 1 - 2 * vv[i]。
AC Code:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
using namespace std;
static const int MAX_N = 5005;
int segtree[MAX_N << 2];
int vv[MAX_N];
void PushUp(int rt){
segtree[rt] = segtree[rt << 1] + segtree[rt << 1 | 1];
}
void build(int l, int r, int rt){ //建树
segtree[rt] = 0;
if(l == r) return;
int m = (l + r) >> 1;
build(lson);
build(rson);
}
void update(int p, int l, int r, int rt){ //单点插值
if(l == r){
segtree[rt]++;
return;
}
int m = (l + r) >> 1;
if(p <= m) update(p, lson);
else update(p, rson);
PushUp(rt);
}
int query(int L, int R, int l, int r, int rt){ //区间求和(逆序数)
if(l >= L && r <= R){
return segtree[rt];
}
int m = (l + r) >> 1;
int res = 0;
if(L <= m) res += query(L, R, lson);
if(R > m) res += query(L, R, rson);
return res;
}
int main(){
int n;
while(scanf("%d", &n) != EOF){
build(0, n - 1, 1);
int sum = 0;
for(int i = 0; i < n; i++){
scanf("%d", &vv[i]);
sum += query(vv[i], n - 1, 0, n - 1, 1);
update(vv[i], 0, n - 1, 1);
}
int min_res = sum;
for(int i = 0; i < n; i++){
sum += n - 1 - 2 * vv[i]; //0 ---> n - 1 逆序数
min_res = min(min_res, sum);
}
printf("%d\n", min_res);
}
return 0;
}