【PAT甲级】1146 Topological Order(25 分)(拓扑排序)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
题意:给定一个有向无环图,然后给一些序列,问是否为图的拓扑排序
思路:裸的拓扑排序
代码:
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
#include <cstdio>
#include <string>
#include <vector>
#include <climits>
#include <sstream>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e3+5;
int n,m;
vector<int>g[N];
vector<int>res;
int in[N],deg[N];
///拓扑排序
bool topp(vector<int>& vec) {
for(auto u:vec) {
if(deg[u]!=0) return false;
for(auto v:g[u]) {
deg[v]--;
}
}
return true;
}
int main() {
scanf("%d%d",&n,&m);
mem(in,0);
for(int i=0; i<m; i++) {
int u,v;
scanf("%d%d",&u,&v);
g[u].push_back(v);
in[v]++;
}
int k;
scanf("%d",&k);
for(int i=0; i<k; i++) {
for(int h=0; h<N; h++) {
deg[h]=in[h];
}
int x;
vector<int>ggg;
for(int j=0; j<n; j++) {
scanf("%d",&x);
ggg.push_back(x);
}
if(!topp(ggg)) {
res.push_back(i);
// printf("i=%d\n",i);
}
}
for(int i=0; i<res.size(); i++) {
if(i) printf(" %d",res[i]);
else printf("%d",res[i]);
}
return 0;
}
推荐阅读
-
PAT (Advanced Level) Practice 1146 Topological Order (25分) (拓扑序列的判断)
-
PAT甲级--1146 Topological Order(25 分)【判断是否为拓扑序列】
-
1146 Topological Order (25分)
-
1146 Topological Order (25分)
-
1146 Topological Order (25分)
-
【PAT甲级A1146】Topological Order (25分)(c++)
-
pat 甲级 排序 A1089 Insert or Merge (25分)归并排序
-
1146 Topological Order (25分)
-
PAT甲级A1146 Topological Order(25 分)
-
PAT甲级1146 Topological Order (25分) 拓扑排序