欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU3342——Legal or Not【拓扑排序】

程序员文章站 2024-03-19 11:59:58
...

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11067    Accepted Submission(s): 5185


 

Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

 

 

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

 

 

Output

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".

 

 

Sample Input

 

3 2 0 1 1 2 2 2 0 1 1 0 0 0

 

 

Sample Output

 

YES NO

 

 

Author

[email protected]

 

 

Source

HDOJ Monthly Contest – 2010.03.06

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1285 2647 3333 3339 3341 

 

 

Statistic | Submit | Discuss | Note

拓扑排序板子题。主要就是判断有没有成环。如果最后的拓扑序列的长度,原来的数量则没有出现环,否则出现环。

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;
const int MAXN=100010;
//vector<int> graph[MAXN];
int n,m,cnt,top;
int a[MAXN],deg[MAXN],head[MAXN];
struct node{
    int to,next;
}edge[MAXN];
void addEdge(int u,int v){
    edge[++top].to=v;
    edge[top].next=head[u];
    head[u]=top;
    deg[v]++;
}
void topsort(){
    queue<int> qu;
    for(int i=0;i<n;i++){
        if(deg[i]==0) qu.push(i);
    }
    while(!qu.empty()){
        int x=qu.front();qu.pop();
        a[++cnt]=x;
        for(int i=head[x];i!=-1;i=edge[i].next){
            int y=edge[i].to;
            if(--deg[y]==0) qu.push(y);
        }
    }
}
int main(){
    while(~scanf("%d%d",&n,&m)&&n,m){
        cnt=0;
        top=0;
        memset(deg,0,sizeof(deg));
        memset(a,0,sizeof(a));
        memset(head,-1,sizeof(head));
        for(int i=1;i<=m;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            addEdge(x,y);
        }
        topsort();
        //for(int i=1;i<=cnt;i++) printf("%d ",a[i]);
        if(cnt==n) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

相关标签: 2018暑假集训