欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

UVa 1583 - Digit Generator

程序员文章站 2024-02-25 08:10:46
...

1583 - Digit Generator

Time limit: 3.000 seconds


先打表。


For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M
is the digitsum of N, we call N a generator of M.
For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of
256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one
generator. For example, the generators of 216 are 198 and 207.
You are to write a program to find the smallest generator of the given integer.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case takes one line containing an integer N,
1 ≤ N ≤ 100, 000.
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to
contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does
not have any generators, print ‘0’.
Sample Input
3
216
121
2005
Sample Output
198
0
1979

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#include<string.h>
#define maxn 100000
#define ll long long
#define INF 0x3f3f3f3f3f3f3f3f
using namespace std;
int a[maxn+10];
void init(){
    memset(a,0,sizeof(a));
    int n,m,i;
    for(i=1;i<=maxn;i++){
        n=m=i;
        while(m){
            n+=m%10;
            m=m/10;
        }
        if(a[n]==0){
            a[n]=i;
        }
        else{
            a[n]=min(a[n],i);
        }
    }
}
int main()
{
//  freopen("input.txt","r",stdin);
//  freopen("output.txt","w",stdout);
    int t,i,n;
    scanf("%d",&t);
    init();
    while(t--){
        scanf("%d",&n);
        printf("%d\n",a[n]);
    }
    return 0;
}
相关标签: 基础

上一篇: 最长子序列

下一篇: 数组学习