欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

uva 1583 Digit Generator

程序员文章站 2024-02-24 23:46:22
...

原题:
For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M
is the digitsum of N, we call N a generator of M. For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one
generator. For example, the generators of 216 are 198 and 207. You are to write a program to find the smallest generator of the given integer.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case takes one line containing an integer N,
1 ≤ N ≤ 100, 000.
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to
contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does
not have any generators, print ‘0’.

Sample Input
3
216
121
2005

Sample Output
198
0
1979

中文:

给你一个数x,如果x可以由y加上y的每一位得到,那么y是x的生成元~
现在给你一个数n从1到100000,问你这个数最小的生成元是多少?

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;

int solve(int x)
{
    int ans=0;
    while(x)
    {
        ans+=x%10;
        x/=10;
    }
    return ans;
}

int main()
{
    ios::sync_with_stdio(false);
    int t,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        int tmp=n,dig=0;
        while(tmp)
        {
            tmp/=10;
            dig++;
        }
        int flag=0;
        for(int i=n-dig*9;i<n;i++)
        {
            if(i+solve(i)==n)
            {
                flag=1;
                cout<<i<<endl;
                break;
            }
        }
        if(!flag)
            cout<<0<<endl;
    }
    return 0;
}

解答:

紫书上的例题,蛮简单的,书上是打表做的。

其实可以考虑一下,一个数的生成元不可能超过它本身,那最小的时候也就是n减去每一位全都是9的情况。
如此下来枚举即可

相关标签: uva