欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

数数字(Digit Counting, ACM/ICPC Danang 2007, UVa1225)

程序员文章站 2022-03-14 23:09:57
...

1225 Digit Counting

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is: 12345678910111213 In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program. Input The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets. For each test case, there is one single line containing the number N. Output For each test case, write sequentially in one line the number of digit 0, 1, . . . 9 separated by a space.

Sample Input

2

3

13

Sample Output

0 1 1 1 0 0 0 0 0 0

1 6 2 2 1 1 1 1 1 1

有两种解法。第一种是先进行预处理,再根据输入的N去查表,适合有许多个N要输入处理:

#include<stdio.h>
int count[10000][10];

int main() {
    int T, N;
    for(int i = 0; i < 10; ++i)
        count[0][i] = 0;
    for(int i = 1; i < 10000; ++i) {
        for(int k = 0; k < 10; ++k)
            count[i][k] = count[i-1][k];
        for(int j = i; j; j/=10)
            count[i][j%10]++;
    }
    scanf("%d", &T);
    while (T--) {
        scanf("%d", &N);
        for(int i = 0; i < 9; i++)
            printf("%d ", count[N][i]);
        printf("%d\n", count[N][9]);
    }
    return 0;
}

第二种是不进行预处理,每输入一个N就对1~N处理一次。似乎效率上不如第一种方案:

#include<stdio.h>
#include<string.h>

int main() {
    int T, N;
    int count[10];
    
    scanf("%d", &T);
    while (T--) {
        scanf("%d", &N);
        memset(count, 0, sizeof(count));
        for (int i = 1; i <= N; i++) {
            int x = i;
            while(x > 0) {
                count[x%10]++;
                x /= 10;
            }
        }
        for(int i = 0; i < 9; i++)
            printf("%d ", count[i]);
        printf("%d\n", count[9]);
    }
    return 0;
}

 

相关标签: 算法竞赛