欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

pat1045

程序员文章站 2022-07-15 14:02:11
...

1045. Favorite Color Stripe (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7

题目大致意思是:要找一个最长非降子序列

解题思路大概如下:使用动态规划的思想,对于第k位输入的值,令包含其自身的最长非降子序列长度为d[k]

则d[k]=max(d[k],d[i]+1)(i<k&&第i 位的优先级高于第j位的优先级)

并且需要注意的是,因为此处对于d[k]的定义是包含自身的最长子序列,所以d[k]初始化应该是0,当这个元素在之前的所输入的喜欢的颜色中时才置为1;

#include <iostream>
using namespace std;
int prio[300];
bool tru[300];
int longest[10005];
int in[10005];

int main(int argc, const char * argv[]) {
    int n,m,l;
    cin>>n;
    cin>>m;
    for(int i=0;i<300;i++){
        tru[i]=false;
        prio[i]=-1;
    }
    for(int i=0;i<10005;i++)
        longest[i]=1;
    for(int i=0;i<m;i++){
        int tmp;
        cin>>tmp;
        tru[tmp]=true;
        //in[tmp]=tmp;//记录下来输入值
        prio[tmp]=i;
    }
    cin>>l;
    int maxx=-1;
    for(int i=0;i<l;i++)
        cin>>in[i];
    for(int i=0;i<l;i++){
        if(tru[in[i]]){
            longest[i]=1;//注意应该在这里才是把值设为1,因为根据之前关于longest的定义,是包含这个节点的最长,所以需要将一开始设为0(因为可能有些j节点不是待选的,然后本来应该是0,然后在这里变成了满足下面的条件使得longest变成了2  例子::j不是喜欢的颜色但是其prio=0;并且其longest=1;则1+1会大于longsset[i])
            for(int j=0;j<i;j++){
                    if(longest[j]+1>longest[i]&&prio[in[j]]<=prio[in[i]])//这里的最长指的是包含了第j个的最长
                        longest[i]=longest[j]+1;
            }
            maxx=max(longest[i],maxx);

        }
        
    }
    cout<<maxx;
    return 0;
}

上一篇: PAT1045

下一篇: C语言逆序的三位数