欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ - 3263Tallest Cow(前缀和+差分)

程序员文章站 2022-07-12 17:39:01
...

Language:Default

Tallest Cow

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4544   Accepted: 2130

Description

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

Line 1: Four space-separated integers: NIH and R 
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ AB ≤ N), indicating that cow A can see cow B.

Output

Lines 1..N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8

Sample Output

5
4
5
3
4
4
5
5
5

Source

USACO 2007 January Silver

 

 

 

 

题意:

出n头牛的身高,和m对关系:a与b可以相互看见。

已知最高的牛为第p头,身高为h。求每头牛的身高最大可能是多少?

分析:
第p头最高h,比他矮的最高一定是h-1,即求出每一头比最高的那头牛矮多少d[i];

a与b相互看见:他们中间的牛(a[i+1]到b[i-1])身高都比他们矮,于是把他们身高都减去1即可。

维护一个差分数列即可。

坑点:输入数据可能有重复和可能位置顺序不对。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const int N = 2e5 + 100;
map<pair<int,int>, bool>vis;
int c[N], d[N];

int main()
{
    int n, p, h, m;
    cin>>n>>p>>h>>m;
    for(int i = 1; i <= m; i++)
    {
        int a, b;
        cin>>a>>b;
        if(a > b)
            swap(a, b);
        if(vis[make_pair(a,b)])
            continue;
        d[a+1]--;
        d[b]++;
        vis[make_pair(a,b)] = 1;
    }
    for(int i = 1; i <= n; i++)
    {
        c[i] = c[i-1]+d[i];
        cout<<h+c[i]<<'\n';
    }
    return 0;
}