Tallest Cow POJ - 3263(差分)(pair)
FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1…N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.
FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.
For each cow from 1…N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.
Input
Line 1: Four space-separated integers: N, I, H and R
Lines 2… R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.
Output
Lines 1… N: Line i contains the maximum possible height of cow i.
Sample Input
9 3 5 5
1 3
5 3
4 3
3 7
9 8
Sample Output
5
4
5
3
4
4
5
5
5
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
using namespace std;
int n,i,h,r;
map <pair<int,int>,int> mp;
int c[10009];
int main(){
while(~scanf("%d%d%d%d",&n,&i,&h,&r)){
memset(c,0,sizeof(c));
mp.clear();
for(int i=1;i<=r;i++){
int ta,tb;
scanf("%d%d",&ta,&tb);
if(ta>tb) swap(ta,tb);
if(mp[make_pair(ta,tb)]) continue;
c[ta+1]--;c[tb]++;
mp[make_pair(ta,tb)]=1;
}
printf("%d\n",c[1]+h);
for(int i=2;i<=n;i++){
c[i]+=c[i-1];
printf("%d\n",c[i]+h);
}
}
}
上一篇: [bzoj3043]IncDec Sequence_差分
下一篇: 牛客练习赛(49)筱玛爱线段树