欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ - 3263 Tallest Cow【差分】

程序员文章站 2022-07-12 17:39:07
...

【题目描述】
FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1…N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1…N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

【输入】
Line 1: Four space-separated integers: N, I, H and R
Lines 2… R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

【输出】
Lines 1… N: Line i contains the maximum possible height of cow i.

【样例输入】
9 3 5 5
1 3
5 3
4 3
3 7
9 8

【样例输出】
5
4
5
3
4
4
5
5
5

题目链接:https://vjudge.net/problem/POJ-3263

代码如下:

#include <iostream>
#include <map>
#include <algorithm>
using namespace std;
static const int MAXN=10000;
int a[MAXN+10],b[MAXN+10];
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int N,I,H,R;
    cin>>N>>I>>H>>R;
    map<pair<int,int>,bool> existed;
    for(int i=1;i<=R;i++)
    {
        int l,r;
        cin>>l>>r;
        if(l>r)
            swap(l,r);
        if(existed[make_pair(l,r)])
            continue;
        b[l+1]--;
        b[r]++;
        existed[make_pair(l,r)]=true;
    }
    for(int i=1;i<=N;i++)
    {
        a[i]=a[i-1]+b[i];
        cout<<a[i]+H<<endl;
    }
    return 0;
}