欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Intersecting Lines POJ - 1269(计算几何判断直线位置关系+求直线交点)

程序员文章站 2022-03-30 08:41:15
...

Intersecting Lines POJ - 1269

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input
The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output
There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read “END OF OUTPUT”.
Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

分析:

先判断两条直线是不是同线,不是的话再判断是否平行,再不是的话就只能是相交的,求出交点。

1)如何判断是否同线?

由叉积的原理知道如果p1p2p3共线的话那么(p2p1)×(p3p1)=0。因此如果p1p2p3共线,p1p2p4共线,那么两条直线共线。求p1p2p1p3的叉积和p1p2p1p4的叉积,叉积都为0说明共线。

2)如何判断是否平行?

由向量可以判断出两直线是否平行。如果两直线平行,那么向量p1p2p3p4也是平行的。即((p1.xp2.x)(p3.yp4.y)(p1.yp2.y)(p3.xp4.x))=0说明向量平行。

3)如何求出交点?

假设交点为p0=(x0,y0)

则有:

(p1p0)×(p2p0)=0

(p3p0)×(p4p0)=0

展开后得到

(y1y2)x0+(x2x1)y0+x1y2x2y1=0

(y3y4)x0+(x4x3)y0+x3y4x4y3=0

相当于解二元一次方程组

a1x+b1y+c1=0

a2x+b2y+c2=0

所以解为

x=c1b2c2b1a2b1a1b2

y=a2c1a1c2a1b2a2b1

直接带入即可

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-8;
struct Point{
    double x,y;
};
double isline(Point a,Point b,Point c){
    return (c.x - a.x) * (b.y - a.y) - (c.y - a.y) * (b.x - a.x);
}
double isparl(Point a,Point b,Point c,Point d){
    return (b.x - a.x) * (d.y - c.y) - (b.y - a.y) * (d.x - c.x);
}
void solve(Point p1,Point p2,Point p3,Point p4){
    if(isline(p1,p2,p3) == 0 && isline(p1,p2,p4) == 0)
        puts("LINE");
    else if(isparl(p1,p2,p3,p4) == 0)
        puts("NONE");
    else{
        double a1 = p1.y - p2.y;
        double b1 = p2.x - p1.x;
        double c1 = p1.x * p2.y - p2.x * p1.y;
        double a2 = p3.y - p4.y;
        double b2 = p4.x - p3.x;
        double c2 = p3.x * p4.y - p4.x * p3.y;
        double x = (b2 * c1 - b1 * c2) / (b1 * a2 - b2 * a1);
        double y = (a2 * c1 - a1 * c2) / (a1 * b2 - a2 * b1);
        printf("POINT %.2f %.2f\n",x,y);
    }
}
int main(){
    int n;
    Point p1,p2,p3,p4;
    while(scanf("%d",&n) != EOF){
        printf("INTERSECTING LINES OUTPUT\n");
        while(n--){
            scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&p1.x,&p1.y,&p2.x,&p2.y,&p3.x,&p3.y,&p4.x,&p4.y);
            solve(p1,p2,p3,p4);
        }
        printf("END OF OUTPUT\n");
    }
    return 0;
}