POJ 1979 Red and Black
Red and Black
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9/
…#.
…#
…
…
…
…
…
#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.
…
11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0\
Sample Output
45
59
6
13
代码
#include<cstdio>
using namespace std;
int N,M,arr;
char filed[1005][1005];
void dfs(int x,int y){
arr++;
filed[x][y]='1'; \\四个方向
if(x-1>=0 && x-1<N && y>=0 && y<M && filed[x-1][y]=='.'){
dfs(x-1, y);
}
if(x+1>=0 && x+1<N && y>=0 && y<M && filed[x+1][y]=='.'){
dfs(x+1,y);
}
if(x>=0 && x<N && y-1>=0 && y-1<M && filed[x][y-1]=='.'){
dfs(x,y-1);
}
if(x>=0 && x<N && y+1>=0 && y+1<M && filed[x][y+1]=='.'){
dfs(x,y+1);
}
return ;
}
int main(){
while(1){
scanf("%d %d",&M,&N);
if(N==0 && M==0)
break;
arr=0;
for(int i=0;i<N;i++)
scanf("%s",filed[i]);
for(int i=0;i<N;i++)
for(int j=0;j<M;j++){
if(filed[i][j]=='@'){
dfs(i,j);
}
}
printf("%d\n",arr);
}
return 0;
}
下一篇: 深度优先和广度优先
推荐阅读
-
POJ 1979 Red And Black 红与黑DFS深搜 AC代码C++
-
ZOJ4048 Red Black Tree(The 2018 ACM-ICPC Asia Qingdao Regional Contest, Online,二分+LCA)
-
POJ3364 HDU1802 UVA11231 Black and white painting【数学】
-
Red and Black HDU 1312
-
Red and Black(DSF)
-
基础数据结构和算法十一:Red-black binary search tree
-
POJ - 1979 (dfs)
-
Red and Black——个人c++解
-
Red and Black-----BFS(水题)
-
dfs/bfs--Red and Black