欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Red and Black-----BFS(水题)

程序员文章站 2022-05-21 17:49:47
...

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output
45
59
6
13

裸的BFS,直接套模板就行了,我也是小白,多多包涵,代码如下:

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
const int N=30;
int n,m;
int ex,ey;
int bj[N][N];
char tu[N][N];
struct peo{
	int x,y;
};
queue<peo> que;
int d[4][2]={1,0,-1,0,0,1,0,-1};
void bfs(int x,int y)
{
	memset(bj,0,sizeof(bj));
	peo t,tt;
	t.x=x;
	t.y=y;
	que.push(t);
	bj[x][y]=1;
	while(!que.empty())
	{
		t=que.front();
		que.pop();
		for(int i=0;i<4;i++){
			int dx=t.x+d[i][0];tt.x=dx;
			int dy=t.y+d[i][1];tt.y=dy;
			if(tu[dx][dy]=='#'||dx<0||dx>=m||dy<0||dy>=n||bj[dx][dy])continue;
			que.push(tt);
			bj[dx][dy]=1;
		}
	}
}
int main()
{
	
	while(~scanf("%d%d",&n,&m)&&n&&m)
	{
		for(int i=0;i<m;i++)
		for(int j=0;j<n;j++)
		{
			cin>>tu[i][j];
			if(tu[i][j]=='@')ex=i,ey=j;
		}
		bfs(ex,ey);
		int ans=0;
		for(int i=0;i<m;i++)
		for(int j=0;j<n;j++)
		ans+=bj[i][j];
		cout<<ans<<endl;
	}
	return 0;
}

欢迎任何形式的转载,但是请标注来源!!!