Red and Black(DSF)
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles,
he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#[email protected]#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
很水的一道题,直接DSF便利一遍就好了
具体代码:
#include<iostream>
#include<cstdio>
#include<bits/stdc++.h>
char str[21][21];
int w,h,ans;
int x[4]={0,-1,1,0};
int y[4]={1,0,0,-1};
void DSF(int a,int b)
{
for(int i=0;i<4;i++)
{
if(a>=0&&b>=0&&a<h&&b<w&&str[a+x[i]][b+y[i]]=='.')
{
ans++;
str[a+x[i]][b+y[i]]='#';
DSF(a+x[i],b+y[i]);
}
}
}
int main()
{
while(scanf("%d%d",&w,&h),w!=0||h!=0)
{
int a,b;
ans=1;
for(int i=0;i<h;i++)
{
scanf("%s",str[i]);
for(int j=0;j<w;j++)
if(str[i][j]=='@')a=i,b=j;
}
DSF(a,b);
printf("%d\n",ans);
}
return 0;
}
下一篇: 蓝桥杯--穿越雷区(宽度优先搜索)
推荐阅读
-
Red Hat Enterprise Linux / CentOS 7 yum安装zabbix4.0
-
Red Hat Enterprise Linux / CentOS 7 yum安装zabbix4.0
-
Win7下硬盘安装 Red Hat Enterprise Linux 6.0 ES图文方法
-
映众GTX1080 Black冰龙黑金版显卡天梯图评测和拆解
-
Red Hat Linux,Apache2.0+Weblogic9.2负载均衡集群安装配置
-
Red Hat Linux上使用BIND建立DNS服务器
-
赛睿Sensei 310 Glossy Red火星红开箱图赏:鲜红夺目
-
经过了近两年的跳票后 RED Hydrogen One钛合金版终于开始出货
-
西数发布WD Black SN750 SSD:游戏模式一键加速
-
Red Hat宣称云计算比微软强大 无视VMware