欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ - 1979 (dfs)

程序员文章站 2022-05-21 17:54:07
...

POJ - 1979 (dfs)

题目正文如下:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile //可走的

‘#’ - a red tile //不可走的

‘@’ - a man on a black tile(appears exactly once in a data set) //人的起始位置

The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
//对于每个数据,您的程序应该输出一行,其中包含他可以从初始瓷砖(包括它本身)到达的瓷砖数量。

Sample Input
POJ - 1979 (dfs)
//用截图形状看得比较清楚

Sample Output

45
59
6
13

题目分析:
其实题目就是要求对每个输入的地图,从’@‘开始进行深度搜索,把所有能走的’.'都走一遍,每走一格答案就加一, 刚开始站的位置算一格。

AC代码如下:

#include<stdio.h>
#include<string.h>
int W,H,sum;	//行数,列数,答案
char room[20][20];  //地图
void dfs(int x,int y)
{	
	int dx,dy,nx,ny;
	sum++;					//计算砖块个数
	room[x][y]='#';				//搜索过的将该位置置换为#,防止再次搜索
	for(dx=-1;dx<=1;dx++)
		for(dy=-1;dy<=1;dy++)
	{	nx=x+dx;
		ny=y+dy;
		if(dx==0||dy==0)		//控制上下左右四个方向
		{if(0<=nx&&nx<H&&0<=ny&&ny<W&&room[nx][ny]=='.') dfs(nx,ny);}	//如果没有出界且符合条件,则dfs
	}
}
int main()
{	int i,j;
	void dfs(int x,int y);
	while(~scanf("%d %d",&W,&H))
	{	sum=0;				//重置砖块个数
		memset(room,0,sizeof(room));	//重置数组
		if(!W&&!H) break;		//都为0,则退出
		for(i=0;i<H;i++)
		{	for(j=0;j<W;j++)
			scanf(" %c",&room[i][j]);	//输入
		}
		for(i=0;i<H;i++)
			for(j=0;j<W;j++)
			if(room[i][j]=='@') dfs(i,j);	//寻找@,并从@开始深度优先搜索
		printf("%d\n",sum);
	}
	return 0;
}

上一篇: smarty模板如何向html中