Red and Black
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 22300 | Accepted: 12041 |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can
move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#[email protected]#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### [email protected] ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
Source
Japan 2004 Domestic
题意:
首先这是一个图,' . '代表黑砖,‘#’代表红砖,‘@’表示主人公呆的那块黑砖。
题意:
首先这是一个图,' . '代表黑砖,‘#’代表红砖,‘@’表示主人公呆的那块黑砖。
红砖不能走。仅仅能沿着黑砖走,每次走一步。问能走到的黑砖的最大数目!
金典DFS;
注意边界,递归结束条件!
上代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define maxn 25
#define MM 10000000
char s[maxn][maxn];
int w[maxn][maxn]; //标记走过的点
int sx,sy;
int conut; //计数
int n,m;
int xx[]={0,0,1,-1};
int yy[]={1,-1,0,0};
int dfs(int x,int y)
{
if(s[x][y]=='#' || w[x][y])
return 0;
conut++;
w[x][y]=1;
for(int i=0;i<4;i++)
{
int xi=x+xx[i];
int yi=y+yy[i];
if(xi>=0 && xi<n && yi>=0 && yi<m)
dfs(xi,yi);
}
return conut;
}
int main()
{
while(~scanf("%d%d",&m,&n))
{
if(m==0 && n==0)
break;
memset(w,0,sizeof(w));
conut=0;
for(int i=0;i<n;i++)
{
scanf("%s",s[i]); //逐行输入
for(int j=0;j<m;j++)
if(s[i][j]=='@')//标记下起点
{
sx=i;
sy=j;
}
}
int k=dfs(sx,sy);
printf("%d\n",k);
}
return 0;
}