Red and Black POJ - 1979
题目:
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#[email protected]#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
[email protected]
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
题意:
给你连个数字n和m,代表图有m行n列,(图的规格是m*n),然后就是一个地图,“.”代表黑色的地板,“#”代表红色的地板,“@”代表男人所在的位置,男人每一次可以向他的前后左右移动一步,而且他只能在黑色的地板上进行移动,让你求出男人可能的移动步数;
思路:
深度优先搜索;
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
char map[21][21];
int book[21][21];
int sx,sy;
int sum;
int nextt[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
void DFS(int x,int y)
{
for(int i=0; i<4; i++)
{
int tx=x+nextt[i][0];
int ty=y+nextt[i][1];
if(tx<0||tx>=m||ty<0||ty>=n)
continue;
if(map[tx][ty]=='#'||book[tx][ty]==1)
continue;
sum++;
book[tx][ty]=1;
DFS(tx,ty);
}
return ;
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0)
break;
sum=1;
memset(map,0,sizeof map);
memset(book,0,sizeof book);
for(int i=0; i<m; i++)
{
scanf("%s",map[i]);
for(int j=0; j<n; j++)
{
if(map[i][j]=='@')
{
sx=i;
sy=j;
}
}
}
//printf("%d %d\n",sx,sy);
book[sx][sy]=1;
DFS(sx,sy);
printf("%d\n",sum);
}
return 0;
}
上一篇: 广度优先算法
下一篇: poj-3984-迷宫问题
推荐阅读
-
POJ 1979 Red And Black 红与黑DFS深搜 AC代码C++
-
ZOJ4048 Red Black Tree(The 2018 ACM-ICPC Asia Qingdao Regional Contest, Online,二分+LCA)
-
POJ3364 HDU1802 UVA11231 Black and white painting【数学】
-
Red and Black HDU 1312
-
Red and Black(DSF)
-
基础数据结构和算法十一:Red-black binary search tree
-
POJ - 1979 (dfs)
-
Red and Black——个人c++解
-
Red and Black-----BFS(水题)
-
dfs/bfs--Red and Black