欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU 1027 Ignatius and the Princess II(全排列next_permutation函数)

程序员文章站 2022-03-22 16:23:46
...

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8658    Accepted Submission(s): 5099


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input

6 4 11 8
 

Sample Output

1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
 

Author
Ignatius.L

题意即求m的全排列的第n个;
直接用求全排列的next_permutation()函数做很简单,值得注意的就是该函数是bool函数,在algorithm头文件里。
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#define N 1005
using namespace std;
int a[N];
int main(){
    int m,n;
    while(~scanf("%d%d",&m,&n)){
        for(int i=0;i<m;i++)
            a[i]=i+1;
        int t=1;
        while(next_permutation(a,a+m)){
            t++;
            if(t==n)
                break;
        }
        for(int i=0;i<m;i++){
            if(i)
                printf(" ");
            printf("%d",a[i]);
        }
        printf("\n");
    }
    return 0;
}