HDU - 1027 Ignatius and the Princess II 全排列
程序员文章站
2022-03-22 13:44:45
...
Ignatius and the Princess II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9380 Accepted Submission(s): 5481
Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for
you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."
"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
Sample Input
6 4
11 8
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
将一组数据进行全排列,再将排列好的数据按从小到大排列好,如1 2 3三个数全排列可组成123 132 213 231 312 321,第3个为213。可使用STL中的next_permutation函数进行操作。
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int n, m;
int a[1005];
while (~scanf("%d %d", &n, &m))
{
for (int i = 1; i <= n; i++)
{
a[i] = i;
}
m--;
while (m--)
{
next_permutation(a + 1, a + n + 1);
}
printf("%d", a[1]);
for (int i = 2; i <= n; i++)
{
printf(" %d", a[i]);
}
printf("\n");
}
return 0;
}
下一篇: Perl中的特殊符号介绍
推荐阅读
-
HDU1027-Ignatius and the Princess II(全排列问题next_permutation函数的使用)
-
【HDU 1027】全排列 | 逆康托展开 | std::next_permutation | 栈 + 回溯搜索 | N
-
HDU 1027 Ignatius and the Princess II[DFS/全排列函数next_permutation]
-
HDU 1027 Ignatius and the Princess II(全排列)
-
算法模板之全排列(next_permutation实现)(HDU 1027 与 HDU 1755)
-
HDU 1027 Ignatius and the Princess II(全排列next_permutation函数)
-
【排列】HDU1027 Ignatius and the Princess II
-
HDU 1027 Ignatius and the Princess II(全排列问题)
-
HDU - 1027 Ignatius and the Princess II 全排列
-
Ignatius and the Princess II(hdu1027全排列)