欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Ignatius and the Princess II(hdu1027全排列)

程序员文章站 2022-03-22 13:39:41
...

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, “I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too.” Ignatius says confidently, “OK, at last, I will save the Princess.”

“Now I will show you the first problem.” feng5166 says, “Given a sequence of number 1 to N, we define that 1,2,3…N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it’s easy to see the second smallest sequence is 1,2,3…N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It’s easy, isn’t is? Hahahahaha…”
Can you help Ignatius to solve this problem?

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub’s demand. The input is terminated by the end of file.

Output
For each test case, you only have to output the sequence satisfied the BEelzebub’s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input
6 4
11 8

Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

这个题主要是c++STL中全排列算法的应用。
全排列算法有next_permutation()和prev_permutation()两种,是按照一定次序生成一个数列的所有可能的排列。
具体的全排列算法的详细阐述和讲解看这篇文章:
https://blog.csdn.net/c18219227162/article/details/50301513

本题的代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
	int n,m;
	while(cin>>n>>m)
	{
	int a[1010];
	for(int i=1;i<=n;i++)
	{
		a[i]=i;
	}
	sort(a+1,a+n+1);//排序,从第一个字典序开始排列 
	int num=1;//第一个字典序的排列标记为第一个 
	do//当不是第m个排列时继续调用next_permutation()函数进行重排 
	{
		if(num==m)
		{
			for(int i=1;i<=n;i++)
			{
				if(i!=1)
				{
					printf(" ");
				}
				printf("%d",a[i]);
			}
			break;
		}
		num++;//不符合则计数 
	}
	while(next_permutation(a+1,a+n+1));
	cout<<endl;
}
	return 0;
}
相关标签: STL