欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

全排列算法 HDU - 1027 Ignatius and the Princess II

程序员文章站 2022-03-22 13:41:29
...

转载自ACM大神:https://blog.csdn.net/nameofcsdn/article/details/53170690

题目:

Description

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess." 

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" 
Can you help Ignatius to solve this problem? 

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file. 

Output

For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number. 

Sample Input

6 4
11 8

Sample Output

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

解法一:根据阶乘来计算

因为m<=10000<8!,所以当n>8时,前n-8个数一定是1,2,3,4......n-8

代码:

#include<iostream>
using namespace std;

int fac[8] = { 1, 1, 2, 6, 24, 120, 720, 5040 };
int l[9];

void g(int n, int m,int dn)	//n is from 1 to 8
{
	int flag = (m - 1) / fac[n - 1] + 1;
	cout << l[flag]+dn;
	for (int i = flag; i<8; i++)l[i] = l[i + 1];
	if (n>1)
	{
		cout << " ";
		g(n - 1, m - (flag - 1)*fac[n - 1], dn);
	}
	else cout << endl;
}

void f(int n, int m)
{
	if (n > 8)
	{
		for (int i = 1; i <= n - 8; i++)cout << i << " ";
		g(8, m,n-8);
		return;
	}
	g(n, m, 0);
}

int main()
{
	int n, m;
	while (cin >> n >> m)
	{
		for (int i = 0; i < 9; i++)l[i] = i;
		f(n, m);
	}
	return 0;
}

解法二:利用STL

STL中的next_permutation函数可以直接将数组调整到下一顺序的状态。

函数的2个参数,用法和sort里面一样。

比如,对于长为n的数组l,sort(l,l+n)是排序整个数组,next_permutation是给出整个数组的下一顺序的状态。

代码:

#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
	int n, m, s[1000];
	while (cin >> n >> m)
	{
		for (int i = 0; i < n; i++) s[i] = i + 1;
		while (--m) next_permutation(s, s + n );
		for (int i = 0; i < n; i++) cout << s[i] << ((i < n-1) ? " " : "\n");
	}
	return 0;
}

全排列算法:next_permutation( s, s+n )