Ignatius and the Princess II HDU - 1027 全排列
程序员文章站
2022-03-22 13:42:17
...
一、内容
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."
"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
Sample Input
6 4
11 8
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
二、思路
- dfs进行全排列的枚举,每找到一种可能ans++, 只到ans == M 的时候输出结果。
- 利用c++ < algorithm > 中的next_permutation()。 next_permutation()是按照字典序产生排列的,并且是从数组中当前的字典序开始依次增大直至到最大字典序。每调用一次就进行排列一次。
三、代码
#include <cstdio>
const int N = 1005;
int rec[N], n, m, ans;
bool v[N];
void output() {
printf("%d", rec[0]);
for (int i = 1; i < n; i++) {
printf(" %d", rec[i]);
}
puts("");
}
//num 代表已经搜了多少位了
void dfs(int num) {
if (ans >= m) return;
if (num == n) {
ans++;
if (ans == m) output();
return;
}
for (int i = 1; i <= n; i++) {
if (!v[i]) {
v[i] = 1;
rec[num] = i;
dfs(num + 1);
v[i] = 0;
}
}
}
int main() {
while (scanf("%d%d", &n, &m) != EOF) {
ans = 0;
dfs(0);
}
return 0;
}
#include <cstdio>
#include <algorithm>
using namespace std;
const int N = 1005;
int rec[N], n, m, ans;
bool v[N];
void output() {
printf("%d", rec[0]);
for (int i = 1; i < n; i++) {
printf(" %d", rec[i]);
}
puts("");
}
int main() {
while (scanf("%d%d", &n, &m) != EOF) {
for (int i = 1; i <= n; i++) rec[i - 1] = i;
while (--m) {
next_permutation(rec, rec + n);
}
output();
}
return 0;
}
推荐阅读
-
HDU1027-Ignatius and the Princess II(全排列问题next_permutation函数的使用)
-
【HDU 1027】全排列 | 逆康托展开 | std::next_permutation | 栈 + 回溯搜索 | N
-
HDU 1027 Ignatius and the Princess II[DFS/全排列函数next_permutation]
-
HDU 1027 Ignatius and the Princess II(全排列)
-
算法模板之全排列(next_permutation实现)(HDU 1027 与 HDU 1755)
-
HDU 1027 Ignatius and the Princess II(全排列next_permutation函数)
-
【排列】HDU1027 Ignatius and the Princess II
-
HDU 1027 Ignatius and the Princess II(全排列问题)
-
HDU - 1027 Ignatius and the Princess II 全排列
-
Ignatius and the Princess II(hdu1027全排列)