欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

uva679 - Dropping Balls(沾边的树的遍历问题)

程序员文章站 2024-03-18 22:03:16
...
A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each
time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows
the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf
nodes of FBT. To determine a ball’s moving direction a flag is set up in every non-terminal node with

two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node if

the flag’s current value at this node is false, then the ball will first switch this flag’s value, i.e., from

the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise,
it will also switch this flag’s value, i.e., from the true to the false, but will follow the right subtree of
this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at
1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered
from left to right.
      For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1,
2, 3, ..., 15. Since all of the flags are initially set to be false , the first ball being dropped will switch
flag’s values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being
dropped will switch flag’s values at node 1, node 3, and node 6, and stop at position 12. Obviously,
the third ball being dropped will switch flag’s values at node 1, node 2, and node 5 before it stops at

position 10

uva679 - Dropping Balls(沾边的树的遍历问题)


Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.


   Now consider a number of test cases where two values will be given
for each test. The first value is D, the maximum depth of FBT, and
the second one is I,the I-th ball being dropped. You may assumethe
value of I will not exceed the total number of leaf nodes for the
given FBT.
Please write a program to determine the stop position P for each
test case.
For each test cases the range of two parameters D and I is as below
       2<=D<=20,and 1<=I<=524288

不玩了,来中文吧:

样例输入:

4   2

3   4

10 1

2   2

8   128

16  12345

样例输出:

12

7

512

3

255

36358


【题解】:
可以模拟,也可以找思路:
关键点:对于一个结点K,其左子结点、右子结点的编号分别为2*K和2*K+1。
【代码I】(代码包含两种解法了):
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
const int maxs=20;
int s[1<<maxs];
void xx(int D,int I)
{
    long long k=1;
    for(int i=0;i<D-1;i++)
    {
        if(I%2){
            k=k*2;
            I=(I+1)/2;
        }im 
        else {
            k=k*2+1;
            I=I/2;
        }
    }
    printf("%lld\n",k-1);
}
int main()
{
    int D,I;
    while(~scanf("%d%d",&D,&I))
    {
        xx(D,I);
        memset(s,0,sizeof(s));
        int k,n=(1<<D)-1;
        for(int i=0;i<I;i++)
        {
            k=1;
            while(1){
                s[k]=!s[k];
                k=s[k]?2*k:2*k+1;
                if(k>n)break;
            }
        }
        printf("%d\n",k/2);
    }
    return 0;
}



相关标签: c++ 计算机