欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1014 Waiting in Line

程序员文章站 2024-03-18 11:38:04
...

1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

解析:模拟题,利用priority_queue。

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

const int maxn=1005;
const int maxtime=540;
int n,m,k,Q;
struct node{
	int id,stime,etime,ptime;
	//结束时间相同,序号小的优先 
	bool operator<(const node x)const{
		if(etime==x.etime)
			return id>x.id;
		else 
			return etime>x.etime;
	}
}s[maxn];
int wid[25];
priority_queue<node> q;

int main()
{
	scanf("%d%d%d%d",&n,&m,&k,&Q);
	for(int i=1; i<=k; i++)
	{
		scanf("%d",&s[i].ptime);
	}
	int cnt=0;
	node tmp,c;
	
	//n*m个人先入队 
	for(int i=1; i<=m&&cnt<k; i++)
	{
		for(int j=0; j<n&&cnt<k; j++)
		{
			cnt++;
			tmp.id=j;
			tmp.stime=wid[j];
			tmp.etime=wid[j]=tmp.stime+s[cnt].ptime;
			
			s[cnt].id=j;
			s[cnt].stime=tmp.stime;
			s[cnt].etime=tmp.etime;
			
			q.push(tmp);
		}
	}
	for(int i=cnt+1; i<=k; i++)
	{
		tmp=q.top();q.pop();
		
		c.id=tmp.id;
		c.stime=wid[tmp.id];
		c.etime=wid[tmp.id]=c.stime+s[i].ptime;
		
		s[i].id=c.id;
		s[i].stime=c.stime;
		s[i].etime=c.etime;
		
		q.push(c);	
	}
	while(Q--)
	{
		int temp;scanf("%d",&temp);
		if(s[temp].stime>=maxtime)
			printf("Sorry");
		else
			printf("%02d:%02d",s[temp].etime/60+8,s[temp].etime%60);
		
		puts("");
	}
	
	
	return 0;
}