PAT甲级 -- 1014 Waiting in Line (30 分)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
- The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
- Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
- Customeri will take Ti minutes to have his/her transaction processed.
- The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.
At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM
where HH
is in [08, 17] and MM
is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry
instead.
Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry
错误code:
#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;
int n, m, k, qq;
int start_time = 480; //8:00 分钟计
int end_time = 1020; //17:00 分钟计
struct customer
{
int id;
int start; //开始处理时间
int time; //处理时间
int done; //完成时间
customer()
{
start = 2000;
done = -1;
}
} p[1010], c;
int query[1010]; //查询请求
queue<customer> q[25]; //n个队列窗口,size为m
queue<customer> yellow; //在黄线外等待的id
void cal(int num)
{
int h = num / 60;
int minute = num % 60;
printf("%02d:%02d\n", h, minute);
return;
}
int main()
{
scanf("%d%d%d%d", &n, &m, &k, &qq);
for(int i = 1; i <= k; i++)
{
p[i].id = i;
scanf("%d", &p[i].time);
}
for(int i = 0; i < qq; i++)
{
scanf("%d", &query[i]);
}
int process_id = 1;
while(process_id <= n * m)
{
for(int i = 0; i < n; i++)
{
q[i].push(p[process_id++]);
}
}
for(process_id; process_id <= k; process_id++)
yellow.push(p[process_id]); //黄线外等待顾客
int now_time = start_time;
int process_num = 0;
while(1)
{
for(int i = 0; i < n; i++)
{
if(q[i].front().start > now_time)
{
q[i].front().start = now_time;
}
if(q[i].front().done == -1)
q[i].front().done = now_time + q[i].front().time;
}
for(int i = 0; i < n; i++)
{
if(now_time == q[i].front().done)
{
now_time = q[i].front().done;
c = yellow.front();
q[i].push(c);
yellow.pop();
q[i].pop();
}
}
now_time++;
process_num = 0;
for(int i = 0; i < n; i++)
{
if(!q[i].empty())
process_num += 1;
}
if(process_num == 0)
break;
}
for(int i = 0; i < qq; i++)
{
if(p[query[i]].start > end_time)
printf("Sorry\n");
else
cal(p[query[i]].done);
}
return 0;
}
大佬的代码:
#include<stdio.h>
#include<queue>
using namespace std;
int serve_time[1001];
int ans[1001];
queue<int> Q[21];
int main(void){
int w,cap,cus,k;//分别记录窗口数量、窗口最大人数、顾客数量和查询数量
int i,j;
while(scanf("%d%d%d%d",&w,&cap,&cus,&k) != EOF){
for(i = 1; i <= cus; i ++){
scanf("%d",&serve_time[i]);
}
for(i = 0; i < w; i ++){
if(Q[i].empty() == false)Q[i].pop();
}
int sum = 0;
int count = 1;
for(int ti = 0; ti < 540; ti = ti + 1){//以时间来作为循环,这个很关键
for(i = 0; i < w; i ++){
for(j = 0; j < Q[i].size(); j ++){
if(ti == ans[Q[i].front()]){//如果当前队伍的人服务结束了
Q[i].pop();
sum --;
if(!Q[i].empty()){//并且计算当前队伍下一个人的结束时间
int tmp = Q[i].front();
ans[tmp] = ti + serve_time[tmp];//结束时间为当前时间+顾客的服务时间
}
}
}
}
while(sum < w * cap && count <= cus){
int min = 0;
for(i = 0; i < w; i++){
if(Q[min].size() > Q[i].size()){
min = i;
}//找到人最少的那个队伍
if(Q[min].size() == 0) ans[count] = ti + serve_time[count];//如果队伍没人则直接开始服务,并且计算结束时间
if(Q[min].size() < cap && count <= cus){
Q[min].push(count);//否则把让下一个顾客进队
count ++;
sum ++;
}
}
}
}
for(i = 0; i < k; i ++){
int query;
scanf("%d",&query);
if(ans[query] == 0)puts("Sorry");//值为0说明没有被开始服务,只能Sorry
else{
int hour,min;
hour = 8 + ans[query] / 60;
min = ans[query] % 60;
printf("%02d:%02d\n",hour,min);//把时间转换为标准格式并输出
}
}
}
return 0;
}
---------------------
作者:陈小旭
来源:CSDN
原文:https://blog.csdn.net/Apie_CZX/article/details/45537627
版权声明:本文为博主原创文章,转载请附上博文链接!
上一篇: java 设计模式--工厂模式
下一篇: zephyr笔记 2.5.1 FIFOs
推荐阅读
-
PAT 甲级1014 Waiting in Line (30 分)
-
PAT甲级1014 Waiting in Line (30)(30 分)
-
PAT甲级 -- 1014 Waiting in Line (30 分)
-
PAT甲级 1014 Waiting in Line (30 分)
-
PAT甲级1014 Waiting in Line (30 分)
-
PAT甲级 - 1014 Waiting in Line (30 分)
-
PAT 甲级 1014 Waiting in Line (30 分)
-
PAT甲级 1014 Waiting in Line (30 分)
-
PAT甲级 1022 Digital Library (30分)
-
PAT甲级 -- 1131 Subway Map (30 分)