PAT 甲级1014 Waiting in Line (30 分)
1014 Waiting in Line (30 分)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer i will take T i minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer 1 is served at window 1 while customer 2 is served at window 2 . Customer 3 will wait in front of window 1 and customer 4 will wait in front of window 2 . Customer 5 will wait behind the yellow line.
At 08:01, customer 1 is done and customer 5 enters the line in front of window 1 since that line seems shorter now. Customer 2 will leave at 08:02, customer 4 at 08:06, customer 3 at 08:07, and finally customer 5 at 08:10.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.
Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry
HINT
办理业务,有n个窗口每个窗口只能一次排队m个人,
有k个人办理业务,并给出他们办理业务所需要的时间time,查询p个人的办理业务结束时间。
如果开始办理业务时超过了17:00,输出sorry,08:00开始,17:00结束。
如果业务已经开始办理,就继续办理直到办理业务结束。
Code:
#include <iostream>
#include<cstdio>
#include <queue>
#include <string.h>
#define INT_MAX 0x3f3f3f3f
using namespace std;
int main()
{
int N,M,K,Q;
cin>>N>>M>>K>>Q;
queue<int>q[21];
int wait_time[1005];
int work_time[1005];
memset(wait_time,0,sizeof(wait_time));
memset(work_time,0,sizeof(work_time));
for(int i=0;i<K;i++)//先进入一批人
{
cin>>wait_time[i];
work_time[i]=wait_time[i];
if(i<N*M)
{
if(!q[i%N].empty())
wait_time[i]+=q[i%N].back();
q[i%N].push(wait_time[i]);
}
}
if(K>N*M)//如果某个窗口有人办理业务结束,黄线外的人去那个窗口的队尾等候,如果两个窗口同时有人办理业务结束,就选择窗口号较小的
{
for(int j=N*M; j<K; j++)
{
int minn=INT_MAX;
int index;
for(int k=0; k<N; k++)
{
if(q[k].front()<minn)
{
minn=q[k].front();
index=k;
}
}
wait_time[j]+=q[index].back();
q[index].push(wait_time[j]);
q[index].pop();
}
}
int j=0;
int p;
for(int i=0;j<Q;j++)
{
cin>>p;
p--;
if(wait_time[p]-work_time[p]>=540)
cout<<"Sorry"<<endl;
else
{
int hh=8+wait_time[p]/60;
int mm=wait_time[p]%60;
printf("%02d:%02d\n",hh,mm);
}
}
return 0;
}
上一篇: fifo结构及其代码
推荐阅读
-
PAT 甲级1014 Waiting in Line (30 分)
-
PAT甲级1014 Waiting in Line (30)(30 分)
-
PAT甲级1014 Waiting in Line (30 分)
-
PAT 甲级 1014 Waiting in Line (30 分)
-
PAT甲级 1014 Waiting in Line (30 分)
-
PAT甲级 1022 Digital Library (30分)
-
PAT甲级 -- 1131 Subway Map (30 分)
-
【PAT甲级 映射】1022 Digital Library (30 分)
-
PAT甲级 1151 LCA in a Binary Tree (30分) 最近公共祖先
-
【PAT甲级】1091 Acute Stroke (30分)