魔兽世界之二:装备
- 总时间限制:
- 1000ms
- 内存限制:
- 65536kB
- 描述
魔兽世界的西面是红魔军的司令部,东面是蓝魔军的司令部。两个司令部之间是依次排列的若干城市。
红司令部,City 1,City 2,……,City n,蓝司令部
两军的司令部都会制造武士。武士一共有 dragon 、ninja、iceman、lion、wolf 五种。每种武士都有编号、生命值这两种属性。
有的武士可以拥有武器。武器有三种,sword, bomb,和arrow,编号分别为0,1,2。
双方的武士编号都是从1开始计算。红方制造出来的第 n 个武士,编号就是n。同样,蓝方制造出来的第 n 个武士,编号也是n。
不同的武士有不同的特点。
dragon 可以拥有一件武器。编号为n的dragon降生时即获得编号为 n%3 的武器。dragon还有“士气”这个属性,是个浮点数,其值为它降生后其司令部剩余生命元的数量除以造dragon所需的生命元数量。
ninja可以拥有两件武器。编号为n的ninja降生时即获得编号为 n%3 和 (n+1)%3的武器。
iceman有一件武器。编号为n的iceman降生时即获得编号为 n%3 的武器。
lion 有“忠诚度”这个属性,其值等于它降生后其司令部剩余生命元的数目。
wolf没特点。
请注意,在以后的题目里,武士的士气,生命值,忠诚度在其生存期间都可能发生变化,都有作用,武士手中的武器随着使用攻击力也会发生变化。
武士在刚降生的时候有一个生命值。
在每个整点,双方的司令部中各有一个武士降生。
红方司令部按照 iceman、lion、wolf、ninja、dragon 的顺序循环制造武士。
蓝方司令部按照 lion、dragon、ninja、iceman、wolf 的顺序循环制造武士。
制造武士需要生命元。
制造一个初始生命值为 m 的武士,司令部中的生命元就要减少 m 个。
如果司令部中的生命元不足以制造某个按顺序应该制造的武士,那么司令部就试图制造下一个。如果所有武士都不能制造了,则司令部停止制造武士。
给定一个时间,和双方司令部的初始生命元数目,要求你将从0点0分开始到双方司令部停止制造武士为止的所有事件按顺序输出。
一共有两种事件,其对应的输出样例如下:
1) 武士降生
输出样例: 004 blue lion 5 born with strength 5,2 lion in red headquarter
表示在 4点整,编号为5的蓝魔lion武士降生,它降生时生命值为5,降生后蓝魔司令部里共有2个lion武士。(为简单起见,不考虑单词的复数形式)注意,每制造出一个新的武士,都要输出此时司令部里共有多少个该种武士。
如果造出的是dragon,那么还要输出一行,例:
It has a arrow,and it's morale is 23.34
表示该dragon降生时得到了arrow,其士气是23.34(为简单起见,本题中arrow前面的冠词用a,不用an,士气精确到小数点后面2位,四舍五入)
如果造出的是ninja,那么还要输出一行,例:
It has a bomb and a arrow
表示该ninja降生时得到了bomb和arrow。
如果造出的是iceman,那么还要输出一行,例:
It has a sword
表示该iceman降生时得到了sword。
如果造出的是lion,那么还要输出一行,例:
It's loyalty is 24
表示该lion降生时的忠诚度是24。
2) 司令部停止制造武士
输出样例: 010 red headquarter stops making warriors
表示在 10点整,红方司令部停止制造武士
输出事件时:
首先按时间顺序输出;
同一时间发生的事件,先输出红司令部的,再输出蓝司令部的。- 输入
- 第一行是一个整数,代表测试数据组数。
每组测试数据共两行。
第一行,一个整数M。其含义为: 每个司令部一开始都有M个生命元( 1 <= M <= 10000)
第二行:五个整数,依次是 dragon 、ninja、iceman、lion、wolf 的初始生命值。它们都大于0小于等于10000 - 输出
- 对每组测试数据,要求输出从0时0分开始,到双方司令部都停止制造武士为止的所有事件。
对每组测试数据,首先输出“Case:n" n是测试数据的编号,从1开始
接下来按恰当的顺序和格式输出所有事件。每个事件都以事件发生的时间开头,时间以小时为单位,有三位。 - 样例输入
1 20 3 4 5 6 7
- 样例输出
Case:1 000 red iceman 1 born with strength 5,1 iceman in red headquarter It has a bomb 000 blue lion 1 born with strength 6,1 lion in blue headquarter It's loyalty is 14 001 red lion 2 born with strength 6,1 lion in red headquarter It's loyalty is 9 001 blue dragon 2 born with strength 3,1 dragon in blue headquarter It has a arrow,and it's morale is 3.67 002 red wolf 3 born with strength 7,1 wolf in red headquarter 002 blue ninja 3 born with strength 4,1 ninja in blue headquarter It has a sword and a bomb 003 red headquarter stops making warriors 003 blue iceman 4 born with strength 5,1 iceman in blue headquarter It has a bomb 004 blue headquarter stops making warriors
把之前的代码改了改,为了方便通过并没有成立一个关于每种战士的可变长度数组,至少我觉得在将来还是需要的,因为之前那个战士其实并没有消失,所以应该放在数组里储存起来,但是单单仅针对这道题的话,是不需要的,毕竟,能AC就好了。
//
// main.cpp
// Week05Dota2
//
// Created by air on 2018/4/18.
// Copyright © 2018年 air. All rights reserved.
//
//魔兽世界二 - 装备
# include <stdio.h>
# include <stdlib.h>
# include <iostream>
# include <string>
void Ready();
using namespace std;
/* The interface of warriot*/
class warrior{
private:
public:
string weapon[3] = {"sword","bomb","arrow"};
};
/*Initialize of different warriots*/
class dragon : public warrior{
private:
int Nofweapon;
double morale;
public:
dragon(int w,double m):Nofweapon(w),morale(m){}
void reset(int w, double m){
Nofweapon = w;
morale = m;
}
void print(){
printf("It has a %s,and it's morale is %.2f\n",weapon[Nofweapon].c_str(), morale);
}
};
class ninja : public warrior{
private:
int NofWeapon1, NofWeapon2;
public:
ninja(int a, int b):NofWeapon1(a),NofWeapon2(b){}
void reset(int a, int b){
NofWeapon1 = a;
NofWeapon2 = b;
}
void print(){
printf("It has a %s and a %s\n", weapon[NofWeapon1].c_str(), weapon[NofWeapon2].c_str());
}
};
class iceman : public warrior{
private:
int NofWeapon;
public:
iceman(int s):NofWeapon(s){}
void reset(int s){
NofWeapon = s;
}
void print(){
printf("It has a %s\n", weapon[NofWeapon].c_str());
}
};
class lion : public warrior{
private:
int loyalty;
public:
lion(int l):loyalty(l){}
lion():loyalty(0){}
void reset(int l){
loyalty = l;
}
void print(){
printf("It's loyalty is %d\n", loyalty);
}
};
class wolf : public warrior{
public:
void print(){}
};
/* The class of the Team/City*/
class Team{
private:
int label; /* red or blue */
int time; /* time & how many warriors in total */
int count; /* count is the signal of which warrior is going to be born */
int exist[5]; /* intialize the warrior number to 0 */
int liveOfTeam[5]; /* intialize the blood of warrior */
int totalBlood; /* total blood of a team */
string order[5] = {}; /* order of warrior to be produced */
dragon *dra;
ninja *nin;
iceman *ice;
lion *li;
wolf *wo;
public:
int endLabel; /* set it to public in order to control the while loop */
Team( const string orderIn[], int total, int live[], int l);
void print();
void born();
void endprint();
void bornAWarrior(int warrior);
};
/* Initialize the team */
Team::Team(const string orderIn[], int total, int live[], int l){
for(int i = 0; i < 5; i++){
order[i] = orderIn[i];
exist[i] = 0;
liveOfTeam[i] = live[i];
}
totalBlood = total;
time = 0;
count = -1;
label = l;
endLabel = 0;
dra = NULL;
nin = NULL;
ice = NULL;
li = NULL;
wo = NULL;
}
/* born a new warrior */
void Team::born(){
int i,j;
int tmp = count;
if(tmp+1 == 5)
tmp = -1;
if(totalBlood >= 0 && endLabel == 0){
for (i = tmp+1; i < 5; ++i) {
if(totalBlood - liveOfTeam[i] >= 0){
totalBlood -= liveOfTeam[i];
++exist[i];
count = i;
print();
++time;
bornAWarrior(i);
return;
}
}
for(j = 0; j <= tmp; ++j){
if(totalBlood - liveOfTeam[j] >= 0){
totalBlood -= liveOfTeam[j];
++exist[j];
count = j;
print();
++time;
bornAWarrior(j);
return;
}
}
/* if none of above is satisfied, than set the endlabel to 1 and ndprint */
endLabel = 1;
endprint();
}
}
void Team::bornAWarrior(int warrior){
string warriorTo = order[warrior];
if(warriorTo == "dragon"){
if(dra == NULL){
dra = new dragon(time%3,(double)totalBlood/liveOfTeam[warrior]);
}else{
dra->reset(time%3, (double)totalBlood/liveOfTeam[warrior]);
}
dra->print();
}
if(warriorTo == "ninja"){
if(nin == NULL){
nin = new ninja(time%3, (time+1)%3);
}else{
nin->reset(time%3, (time+1)%3);
}
nin->print();
}
if(warriorTo == "iceman"){
if(ice == NULL){
ice = new iceman(time%3);
}else{
ice->reset(time%3);
}
ice->print();
}
if(warriorTo == "lion"){
if(li == NULL){
li = new lion(totalBlood);
}else{
li->reset(totalBlood);
}
li->print();
}
if(warriorTo == "wolf"){
if(wo == NULL){
wo = new wolf();
}
wo->print();
}
}
/* print one line everytime a warrior is born */
void Team::print(){
if(label == 0)
printf("%03d red %s %d born with strength %d,%d %s in red headquarter\n",time,order[count].c_str(),time+1,liveOfTeam[count],exist[count],order[count].c_str());
if(label == 1)
printf("%03d blue %s %d born with strength %d,%d %s in blue headquarter\n",time,order[count].c_str(),time+1,liveOfTeam[count],exist[count],order[count].c_str());
}
/* print one line when no worrior can be born any more */
void Team::endprint(){
if(label == 0)
printf("%03d red headquarter stops making warriors\n",time);
if(label == 1)
printf("%03d blue headquarter stops making warriors\n",time);
}
/* the ready function */
void Ready(){
int total;
int iceman,lion,wolf,ninjia,dragon;
cin >> total;
cin >> dragon >> ninjia >> iceman >> lion >> wolf;
string redOrder[5] = {"iceman","lion","wolf","ninja","dragon"};
string blueOrder[5] = {"lion","dragon","ninja","iceman","wolf"};
int liveOfRed[5] = {iceman,lion,wolf,ninjia,dragon};
int liveOfBlue[5] = {lion,dragon,ninjia,iceman,wolf};
Team red(redOrder,total,liveOfRed,0);
Team blue(blueOrder,total,liveOfBlue,1);
while(red.endLabel == 0 || blue.endLabel == 0){
red.born();
blue.born();
}
}
/* The Main Function */
int main(){
int number;
cin >> number;
int i = 0;
while(number --){
cout << "Case:" << ++i << endl;
Ready();
};
return 0;
}
上一篇: Java编程思想第四版读书笔记
下一篇: 讨论私有,公有,静态属性/方法的区别