欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Is It A Tree?

程序员文章站 2024-03-17 13:38:28
...

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

Is It A Tree?


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

 

判断一个图是否是一个有向树,

1,全图只有一个连通分量。

2,只有一个节点入度为零。

3.其余节点入度必须为1。

 

判断连通分量用并查集,判断节点入度用数组记录每个节点的入度

 

#include <iostream>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 100100
using namespace std;
int n,m,flag,cas;
int Father[N];
int Rank[N];
int ind[N];
void UFDset()
{
    for(int i=1;i<N;i++){
        Father[i]=i;
        Rank[i]=0;
        ind[i]=0;
    }
}

int Find(int x)
{
    if(x!=Father[x])
        Father[x]=Find(Father[x]);
    return Father[x];
}

void Union(int R1,int R2)
{
    int r1=Find(R1),r2=Find(R2);
    if(Rank[r2]>Rank[r1]){
        Father[r1]=r2;
        Rank[r1]++;
    }
    else{
        Father[r2]=r1;
        Rank[r2]++;
    }
}

int main()
{
    UFDset();
    set<int>s;
    set<int>::iterator it;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n<0&&m<0)
            break;
        if(n==0&&m==0)
        {
            int cnt=0,rootnum=0;
            for(it=s.begin();it!=s.end();it++){
                if(Father[*it]==*it)
                    cnt++;
                if(ind[*it]==0)
                    rootnum++;
                if(ind[*it]>1)
                    flag=1;
            }
            if(rootnum!=1&&s.size()!=0)
                flag=1;
            if(cnt>1)
                flag=1;
            if(flag)
                printf("Case %d is not a tree.\n",++cas);
            else
                printf("Case %d is a tree.\n",++cas);
            UFDset();
            flag=0;
            s.clear();
            continue;
        }
        s.insert(n);
        s.insert(m);
        Union(n,m);
        ind[m]++;
    }
    return 0;
}