欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Aggressive cows POJ - 2456 (二分)

程序员文章站 2024-03-16 08:43:22
...

Aggressive cows

 POJ - 2456 

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

题意:给出n个牛槽和m只牛,问牛分布在哪些牛槽里能让各个牛之间的最小距离最大

思路:二分

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 100010
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
using namespace std;

int n,m,a[maxn];
bool judge(int x)
{
    int i;
    int temp = a[1];
    int cnt = 1;
    for(int i=2;i<=n;++i){
        if(a[i]-temp >= x){
            temp = a[i];
            cnt++;
            if(cnt >= m)
                return true;
        }
    }
    return false;
}
int bsearch()
{
    int low =1,high = 1000000,mid;
    while(low<=high){
        mid = (low+high)/2;
        if(judge(mid)){
            low = mid+1;
        }
        else{
            high = mid-1;
        }
    }
    return low-1;  //judge()里符合条件就向右移,所以最后返回low-1
}
int main()
{
    while(scanf("%d %d",&n,&m)!=EOF){
        for(int i=1;i<=n;++i){
            scanf("%d",&a[i]);
        }
        sort(a+1,a+n+1);
        printf("%d\n",bsearch());
    }
    return 0;
}