欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Aggressive cows(poj 2456 二分)

程序员文章站 2024-03-16 08:30:34
...

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
    Output

  • Line 1: One integer: the largest minimum distance
    Sample Input

5 3
1
2
8
4
9
Sample Output

3
Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

题目大意为给一条直线上的n个点,让你随意选取c个点,然后使得这c个点两两之间的最小距离最大,如何选取这c个点使这个最小距离最大,输出最大的最小距离max。

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<math.h>
#include<iostream>
#include<vector>
#include<set>
#include<stack>
#include<map>
#include<queue>
typedef long long ll;
using namespace std;
const int N=100005;
const int INF=0x3f3f3f3f3f;
int a[N];
int n,c;
int voct(int k)
{
    int num=1;
    int ans=1;
    for(int i=2;i<=n;i++)
    {
        if(a[i]-a[num]>=k)
        {
            ans++;
            num=i;
        }
    }
    if(ans>=c)
    {
        return 1;
    }
    else
        return 0;
}
int main()
{
    while(scanf("%d%d",&n,&c)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
           scanf("%d",&a[i]);
        }
        sort(a+1,a+1+n);
        int l=0,r=a[n]/c+1;
        int ok;
        while(l<=r)
        {
              int mid=(l+r)/2;
              if(voct(mid))
              {
                  l=mid+1;
                  ok=mid;
              }
              else
              {
                  r=mid-1;
              }
        }
        printf("%d\n",ok);
    }
    return 0;
}