欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Prime Cuts【预处理】【素数筛法】

程序员文章站 2024-03-08 23:14:52
...

Prime Cuts【预处理】【素数筛法】

有些东西只有你WA的多了,才有发言权。。。。。。——题记

题面:

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list. 

Input

Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd. 

Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output. 

Sample Input

21 2
18 2
18 18
100 7

Sample Output

21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67

 

思路

  这道题其实对素数筛法是一道很严格的题目,他会让我们更加清晰的了解到这个用法,这里的素筛也是我WA了十次的原因,一直开的太小却没有从素筛函数中找BUG成了困扰了我两个多小时的原因。。。。。。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
using namespace std;
typedef long long ll;
bool really[1055];
int sushu[1055];
int dp[1055];       //在此数之前的素数个数(包含目前点)
int cnt_su=1;       //素数个数(总共)
int N,C;
void susai()
{
    memset(really, true, sizeof(really));
    memset(dp, 0, sizeof(dp));
    dp[1]=1;
    sushu[1]=1;
    for(int i=2; i<=1050; i++)
    {
        dp[i]=dp[i-1];
        if(really[i])
        {
            dp[i]++;
            sushu[++cnt_su]=i;
            for(int j=2*i; j<=1050; j+=i) really[j]=false;
        }
    }
}
int main()
{
    susai();
    while(scanf("%d%d",&N,&C)!=EOF)
    {
        printf("%d %d:",N,C);
        int st,en;
        if(dp[N]&1)
        {
            st=max( 1, (dp[N]/2+1)-C+1 );
            en=min( dp[N], (dp[N]/2)+C);
        }
        else
        {
            st=max( 1, dp[N]/2-C+1 );
            en=min( dp[N], dp[N]/2+C);
        }
        for(int i=st; i<=en; i++) printf(" %d",sushu[i]);
        printf("\n");
        printf("\n");
    }
    return 0;
}

 

相关标签: 素数筛法