欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

KMP模板

程序员文章站 2024-03-03 20:26:46
...

一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢? 

Input

输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。 

Output

输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。 

Sample Input

abcde a3
aaaaaa  aa

Sample Output

0
3

 

题意:s2在s1中有几个,s1的长度不重复使用。

需注意的就是s2在s1中是否可以重复。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s1[1000010];
char s2[1000010];
int next[1000010];
int L1,L2;
void getf()
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<L2)
    {
        if(j<0||s2[i]==s2[j])
            next[++i]=++j;
        else
            j=next[j];
    }
}
int main()
{
    while(~scanf("%s",s1))
    {
        scanf("%s",s2);
        L1=strlen(s1);
        L2=strlen(s2);
        getf();
        int ans=0;
        int j=0;
        for(int i=0; i<L1; i++)
        {
            while(j>0&&s1[i]!=s2[j])
                j=next[j];
            if(s1[i]==s2[j])
            {
                j++;
            }
            if(j==L2)
            {
                ans++;
                j=next[j];//s2在s1中可重复使用一段,j=0为s2在s1中不能重复使用一段
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

相关标签: 模板题