二叉树 已知前序中序两个序列,建立二叉树(中序和后序也有)
本文主要讲二叉树的建树,具体的说就是,题目给出你二叉树的前序和中序,你来建树,还有一个题目是给出中序和后序来建树
第一题:A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically
traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.
In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
OutputFor each test case print a single line specifying the corresponding postorder sequence.
Sample Input
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6Sample Output
7 4 2 8 9 5 6 3 1
这个题的意思呢就是给出二叉树的前序和中序,要你求按 后序遍历来输出。
这道题对于初学二叉树的同学来说还是比较难的,对于完全摸不着头绪的同学,建议现在纸上根据两个序列来画出这个树,这一步很重要!!!因为通过画二叉树,你就会发现其中的规律,说白了就是 递归 ,当然,你要画很多个二叉树才能自己独立的写出完整的代码,我就是这样做的,感觉挺有效。
在这,我特意给了画二叉树的具体步骤,有助于大家理解。(见分析中的图片)
分析:
这个题最容易想到的就是先建树,然后再遍历输出,其实可以不用建树,直接输出,那么我分别讲一下两种解法。
第一种 :建树,然后输出。
我们用两个数组把前序和中序存起来,便于查找。
我们知道,前序是 根-左-右,就是先输出根,再左子树,右子树,那么前序的第一个数一定是根,而中序遍历是 左 - 根 - 右 , 根在中间, 那么根据前序来找根,用这个根的数据再到中序中找到下标,从而中序就被分为三部分了,就是 左-根-右,那么再对左 和 右分别进行同样的步骤,具体的就是,用前序的根来去中序中查找下标,下标的左边是左子树,下标的右边是右子树,然后再分别对左右进行同样的步骤。。。。。。很显然,一定要用到递归。下面是我对案例的分析:
字有点丑,大家不要介意啊。
其实这个步骤只是有助于理解二叉树怎么建,对于写算法还是有一丁点差别的,而且这个题还有很多细节问题。
我先把代码给出来吧,然后再进行分析(这个题我给出几个版本的解法,之间有细微的差别):
第一种:在找的时候,没有范围的去找。具体的说就是对于题目给的a,b 数组,在b中找a的元素时,无范围的找。
为什么可以在b中 从0到n的找呢? 那是因为题目数据没有重复的,a中的数组和b中的数组都是独立的,而且这道题给的数据是 一定可以建树的数据。
#include<iostream>
using namespace std;
#include<cstdio>
#include<queue>
#include<string.h>
int n;
int a[1001],b[1001];
int judge[1001]; //判断b中的下标是否用过
struct node
{
int index;
node *left,*right;
node()
{
index = 0;
left = right = NULL;
}
};
int cnt = 0;
node *build( node *root ) //这个函数的返回值有多种写法
{
int t = a[cnt++], i; //从a中取数 去b中查找
for( i = 0 ; i < n ; i++ )
{
if( b[i] == t )
break;
}
judge[i] = 1; //被标记
root = new node();
root->index = t;
if( i > 0 && i < n && judge[i-1] != 1 ) //在b数组中,如果一个数左相邻的数被标记,则不能向左建树
root->left = build(root->left); /****** 这个性质不懂的 可以在纸上多模拟几遍,找一下规律 ******/
if( i >= 0 && i < n-1 && judge[i+1] != 1 )//同样,在b数组中,如果一个数右相邻的数被标记,则不能向右建树
root->right = build(root->right);
return root; //左右都建完,返回根结点
}
int counter = 0;
void postorder(node *root) //这个函数没啥好说的, 模板函数( 上个函数其实也是半个模板 )
{
if( root->left )
postorder(root->left);
if( root->right )
postorder(root->right);
if( counter ) //用来调整输出格式
printf(" ");
counter++;
printf("%d",root->index);
}
int main()
{
while( scanf("%d",&n)==1 && n )
{
counter = 0;
cnt = 0;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(judge,0,sizeof(judge));
for( int i = 0 ; i < n ; i++ )
scanf("%d",&a[i]);
for( int i = 0 ; i < n ; i++ )
scanf("%d",&b[i]);
node *root = NULL;
root = build(root);
postorder(root);
printf("\n");
}
return 0;
}
再说一下有范围的找吧,这个代码更具有普适性,(下次如果给你的数据有不能建树的,你可以用上这个来判断是否可以建树),如果这个题数据再大一点,上一种方法估计就用不了了。
有范围的查找是怎么样的呢?我们先看一下案例,
a :
1 2 4 7 3 5 8 9 6
b :
4 7 2 1 8 5 9 3 6
在b中找到 1 后,自然的将b分为左右两部分,那么在向左建树的时候,查找的范围就是左边的那部分,向右建树的时候,就是右边的部分。
是不是很简单!
那么build()函数就要加上两个参数了,左端点和右端点,有了端点就有了范围,如果在这个范围里找不到,就说明不能建树。
代码如下:
#include<iostream>
using namespace std;
#include<cstdio>
#include<queue>
#include<string.h>
int n;
int a[1001],b[1001];
struct node
{
int index;
node *left,*right;
node()
{
index = 0;
left = right = NULL;
}
};
int cnt = 0;
node *build( node *root ,int left,int right) //左右端点
{
int i;
int t = a[cnt++];
for( i = left ; i < right ; i++ )
{
if( b[i] == t ) // ①
break;
}
root = new node(); /***如需加上是否可以建树的合法判断,在①②③处加(本题不用)***/
root->index = t;
if( i > left && i < right ) // ②
root->left = build(root->left,left,i); //范围一定要非常精确
if( i >= left && i <right-1 ) // ③
root->right = build(root->right,i+1,right);
return root; //左右都建完,返回根结点
}
int counter = 0;
void postorder(node *root) //这个函数没啥好说的, 模板函数( 上个函数其实也是半个模板 )
{
if( root->left )
postorder(root->left);
if( root->right )
postorder(root->right);
if( counter ) //用来调整输出格式
printf(" ");
counter++;
printf("%d",root->index);
}
int main()
{
while( scanf("%d",&n)==1 && n )
{
counter = 0;
cnt = 0;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
//memset(judge,0,sizeof(judge));
for( int i = 0 ; i < n ; i++ )
scanf("%d",&a[i]);
for( int i = 0 ; i < n ; i++ )
scanf("%d",&b[i]);
node *root = NULL;
root = build(root,0,n); //一开始为最大范围
postorder(root);
printf("\n");
}
return 0;
}
第二种:不用先建树,后输出,直接 建的时候就输出,感觉更快一点
这一种,连node的结构体都不用写了,而且代码简洁了许多,这就是递归的神秘之处,运用好的话就有这种效果
代码如下:
#include<iostream>
using namespace std;
#include<cstdio>
#include<queue>
#include<string.h>
int n;
int a[1001],b[1001];
int cnt = 0;
int counter = 0;
void build( int left,int right) //左右端点
{
int i;
int t = a[cnt++];
for( i = left ; i < right ; i++ )
{
if( b[i] == t )
break;
}
if( i > left && i < right )
build(left,i); //范围一定要非常精确
if( i >= left && i <right-1 )
build(i+1,right);
if( counter )
printf(" ");
counter++;
printf("%d",t);
}
int main()
{
while( scanf("%d",&n)==1 && n )
{
counter = 0;
cnt = 0;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
//memset(judge,0,sizeof(judge));
for( int i = 0 ; i < n ; i++ )
scanf("%d",&a[i]);
for( int i = 0 ; i < n ; i++ )
scanf("%d",&b[i]);
build(0,n);
printf("\n");
}
return 0;
}
以上就是对于本题的几个版本的解法,其实差别不太大
下面再看一道变形的题,稍微难一点:
这道题是给出中序和后序,让你判断是否可以建树,并输出前序。
那么思路其实和上边的题一模一样。
再来看一下案例(把它变一下):
中序:(左根右)
4 7 2 1 8 5 9 3 6后序:(左右根)
7 4 2 8 9 5 6 3 1
答案:(前序)
1 2 4 7 3 5 8 9 6
#include<cstdio>
#include<cstring>
#include<math.h>
#include<iostream>
#include<queue>
using namespace std;
char a[30],b[30];
struct node
{
char s;
node *left,*right;
node()
{
left = right = NULL;
}
};
int cnt,len,bigflag;
node *build(node *root,int r,int l)
{
if( bigflag == 1 ) //MMP了 不用建了
return NULL;
root = new node();
root->s = b[--cnt];
int i ;
int flag = 0;
for( i = l ; i < r ; i++ )
if( a[i] == root->s )
{
flag = 1;
break;
}
if( flag == 0 ) //一个数据没找到就 MMP
{
bigflag = 1; //用来判断是否MMP
return NULL;
}
if( i < r-1 ) //右边还有元素
root->right = build(root->right,r,i+1);
if( i > l ) //左边还有元素
root->left = build(root->left,i,l);
return root;
}
void preorder(node *root)
{
printf("%c",root->s);
if( root->left )
preorder(root->left);
if( root->right )
preorder(root->right);
}
int main()
{
int T;
scanf("%d",&T);
while( T-- )
{
scanf("%s%s",a,b);
bigflag = 0;
cnt = strlen(b);
len = cnt;
node *root = NULL;
root = build(root,len,0);
if( bigflag == 0 )
{
preorder(root);
printf("\n");
}
else
printf("MMP!\n");
}
return 0;
}
/*
*/
输入数据in:
A
A
BA
AB
ABC
CAB
BCA
ABC
BCA
BAC
ABDCEFG
ABCDEFG
DBEAFCG
DEBFGCA
EAZGFH
EZGHFA
ABCDEFG
ABCDEFG
LBNVPAECFGQWZUJRHKDTSOIYXM
LNPVBEFCAZWUQRJKHTSOYXMIDG
CBDAIFJEKG
CDBIJFKGEA
BDCA
CADB
DBCA
CABD
BDAC
ACDB
BDAC
ACBD
CEBDA
CEBDA
CAEBD
ACEDB
EBDAC
EBDAC
EBACD
ACEBD
BFACDE
ECDFAB
FABCDE
CDEFAB
BDFACEG
BEGDFAC
EGCBDFA
CEGBDFA
CEGABDF
ACEGBDF
ACFEGBD
FACEDGB
GACEBDFH
BDFHEGAC
EGACHBDF
HBDFCEGA
CEGAFHBD
FHBDACEG
ACEGDFHB
DFHBGACE
GACEHBDF
HBDFCEGA
IFCAGDBHE
BHEIFCGDA
GDAHEBFCI
FCIDAGEBH
ECIFAGDHB
IFCGDAEBH
EBHCIFDAG
DAGBHEIFC
AGDBHEIFC
IFDAGEBHC
DFHJBACEGI
ACEGIHJBDF
HJBDFEGIAC
EGIACBDFHJ
BDFHJIAEGC
EGIACHJBDF
HJBDFEGIAC
GIACEDFHJB
DFHJBACEGI
ACEIGJBDFH
IJKABCDEFGH
HIJKACDEFGB
BCDEFGHIJKA
ABCDEFGHIJK
KABCDFGHIJE
EFHIJKABCDG
GHIJKABCDEF
FGHIJKABCDE
EFGHIKABCDJ
JKBCDEFGHIA
上一篇: HTML5 语义元素
下一篇: linux系统中磁盘管理,分区,挂载教程
推荐阅读
-
二叉树 已知前序中序两个序列,建立二叉树(中序和后序也有)
-
leetcode 106. 从中序与后序遍历序列构造二叉树 105. 从前序与中序遍历序列构造二叉树思考分析
-
PHP实现二叉树深度优先遍历(前序、中序、后序)和广度优先遍历(层次)实例详解
-
c/c++ 用前序和中序,或者中序和后序,创建二叉树
-
【算法】二叉树的前序、中序、后序、层序遍历和还原。
-
牛客网---通过前序遍历序列和中序遍历序列建立二叉树
-
算法 给定二叉树前序和中序序列重建二叉树
-
C#使用前序遍历、中序遍历和后序遍历打印二叉树的方法
-
二叉树的前序遍历、中序遍历和后序遍历(迭代解法)
-
JAVA 实现二叉树建立和先序,中序和后序遍历(递归与非递归)