POJ 2386 Lake Counting
Lake Counting
Description
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John’s field, determine how many ponds he has.
Input
-
Line 1: Two space-separated integers: N and M
-
Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
Output
- Line 1: The number of ponds in Farmer John’s field.
Sample Input
10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.\
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
代码
#include<cstdio>
using namespace std;
int N,M;
char filed[1005][1005];
void dfs(int x,int y){
filed[x][y]='.';
for(int a=-1;a<=1;a++) //循环遍历八个方向
for(int b=-1;b<=1;b++){
int nx=x+a,ny=y+b;
if(nx<N && nx>=0 && ny>=0 && ny<M && filed[nx][ny]=='W')
dfs(nx,ny);
}
return ;
}
int main(){
int arr=0;
scanf("%d %d",&N,&M);
for(int i=0;i<N;i++)
scanf("%s",filed[i]);
for(int i=0;i<N;i++)
for(int j=0;j<M;j++){
if(filed[i][j]=='W'){
dfs(i,j);
arr++; //DP次数即答案
}
}
printf("%d\n",arr);
}
深搜从最开始状态出发,遍历所有可以到达的状态。
上一篇: Lake Counting
下一篇: 聊一聊Promise和Async