Lake Counting
程序员文章站
2022-07-14 20:51:33
...
Description
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John’s field, determine how many ponds he has.
Input
- Line 1: Two space-separated integers: N and M
- Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
Output
- Line 1: The number of ponds in Farmer John’s field.
Sample input
10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.
Sample output
3
解题思路
1.深搜或者广搜
2.并查集
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
using namespace std;
char arr[105][105];
int x,y;
void dfs(int u,int v){
if(u<0||u>=x||v<0||v>=y||arr[u][v]=='.') return; //这里要先判断越界与否再判断是否为0
arr[u][v]='.';
for(int i=-1;i<2;i++){
for(int j=-1;j<2;j++){
if(i==0&&j==0) continue;
else dfs(u+i,v+j);
}
}
}
int main(){
cin>>x>>y;
for(int i=0;i<x;i++){
for(int j=0;j<y;j++){
cin>>arr[i][j];
}
}
int count=0;
for(int i=0;i<x;i++){
for(int j=0;j<y;j++){
if(arr[i][j]=='W'){
count++;
dfs(i,j);
}
}
}
cout<<count<<endl;
return 0;
}
上一篇: Lake Counting
推荐阅读
-
neo4j社区发现算法(Community detection algorithms)-4.The Triangle Counting / Clustering Coefficient
-
Intel发布新一代NUC:搭载第七代Kaby Lake酷睿处理器
-
索泰狂发10款新一代ZBOX迷你机:第七代酷睿Kaby Lake
-
MacBook Pro搭载具体哪款Kaby Lake处理器?
-
1004 Counting Leaves (30 分)(树的遍历)
-
Intel Alder Lake-S桌面CPU浮现:10nm++工艺、LGA1700接口
-
MacBook Pro搭载具体哪款Kaby Lake处理器?
-
Intel 10nm++工艺终于传来喜讯 45W Tiger Lake-H内测中
-
Kaby Lake-X怎么样?Kaby Lake-X i7-7740X/i5-7640X深度评测
-
8代酷睿Coffee Lake首测 Intel i5 8250U移动CPU处理器性能对比评测