Lake Counting
Lake Counting
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 48745 | Accepted: 23941 |
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12 W........WW. .WWW.....WWW ....WW...WW. .........WW. .........W.. ..W......W.. .W.W.....WW. W.W.W.....W. .W.W......W. ..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source
#include <iostream>
#include <cstdio>
#include <math.h>
#include <algorithm>
#include <string.h>
#include <string>
using namespace std;
const int N = 101,M = 101;
char map[N][M];
int n,m;
void dfs(int x,int y){
map[x][y] = '.';
for(int i=-1;i<=1;i++){
for(int j=-1;j<=1;j++){
int x1 = x + i;
int y1 = y + j;
if(x1>=0&&x1<N&&y>=0&&y<M&&map[x1][y1]=='W'){
dfs(x1,y1);
}
}
}
return ;
}
int main(){
ios::sync_with_stdio(false);
while(cin>>n>>m){
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
cin>>map[i][j];
}
}
int res = 0;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(map[i][j] == 'W'){
dfs(i,j);
res++;
}
}
}
cout<<res<<endl;
}
return 0;
}
下一篇: Lake Counting
推荐阅读
-
Kaby Lake-X怎么样?Kaby Lake-X i7-7740X/i5-7640X深度评测
-
8代酷睿Coffee Lake首测 Intel i5 8250U移动CPU处理器性能对比评测
-
Intel即将揭秘第11代核显:10nm Ice Lake年底见
-
Intel Comet Lake家族酷睿i3-10100桌面处理器现身:首次4核8线程
-
Intel:10nm的Ice Lake处理器相比前代有18% IPC提升
-
Intel退役Kaby Lake-G处理器 A/I合体的杰作消失了
-
10代Ice Lake i7单核性能曝光:同频比Skylake提升40%还多
-
性能提升超乎想象!Intel 10nm Ice Lake与锐龙3000系列处理器单核性能曝光
-
Intel Tiger Lake处理器曝光:集成Gen12显卡、性能给力
-
不是九代胜似九代 Intel Whiskey Lake处理器亮点详细介绍