BZOJ 2875 2875: [NOI2012]随机数生成器
程序员文章站
2022-07-03 21:44:00
...
2875: [Noi2012]随机数生成器
Time Limit: 10 Sec Memory Limit: 512 MB
Submit: 2203 Solved: 1202
Description
栋栋最近迷上了随机算法,而随机数是生成随机算法的基础。栋栋准备使用线性同余法(Linear Congruential Me
thod)来生成一个随机数列,这种方法需要设置四个非负整数参数m,a,c,X[0],按照下面的公式生成出一系列随机
数X[n]X[n+1]=(aX[n]+c)mod m其中mod m表示前面的数除以m的余数。从这个式子可以看出,这个序列的下一个数
总是由上一个数生成的。用这种方法生成的序列具有随机序列的性质,因此这种方法被广泛地使用,包括常用的C+
+和Pascal的产生随机数的库函数使用的也是这种方法。栋栋知道这样产生的序列具有良好的随机性,不过心急的
他仍然想尽快知道X[n]是多少。由于栋栋需要的随机数是0,1,…,g-1之间的,他需要将X[n]除以g取余得到他想要
的数,即X[n] mod g,你只需要告诉栋栋他想要的数X[n] mod g是多少就可以了。
Input
6个用空格分割的整数m,a,c,X[0],n和g,其中a,c,X[0]是非负整数,m,n,g是正整数。
g<=10^8
对于所有数据,n>=1,m>=1,a>=0,c>=0,X[0]>=0,g>=1。
Output
输出一个数,即X[n] mod g
Sample Input
11 8 7 1 5 3
Sample Output
2
【样例说明】
计算得X[n]=X[5]=8,故(X[n] mod g) = (8 mod 3) = 2
HINT
Source
题解:
矩乘+快速幂 优化效率
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define LL long long
LL m,a,c,x0,n,g;
LL Mat[3][3],z[10010],cnt;
LL Fast_Mul(LL x,LL y){
LL t=0;cnt=0;
while(y) z[++cnt]=y,y>>=1;
for(int i=cnt;i;i--){
t=(t+t)%m;
if(z[i]&1) t=(t+x)%m;
}
return t;
}
void Fast_Pow(LL zs){
if(zs==1){
Mat[0][0]=1;Mat[1][0]=c%m;Mat[1][1]=a%m;
return ;
}
Fast_Pow(zs>>1);
LL Ma[3][3]={0};
for(int i=0;i<=1;i++)
for(int j=0;j<=1;j++)
for(int k=0;k<=1;k++)
Ma[i][j]=(Ma[i][j]+Fast_Mul(Mat[i][k],
Mat[k][j]))%m;
if(zs&1){
Ma[1][0]=(Ma[1][0]+Fast_Mul(Ma[1][1],c))%m;
Ma[1][1]=Fast_Mul(Ma[1][1],a);
}
for(int i=0;i<=1;i++)
for(int j=0;j<=1;j++) Mat[i][j]=Ma[i][j];
}
int main(){
scanf("%lld%lld%lld%lld%lld%lld",&m,&a,&c,&x0,&n,&g);
Fast_Pow(n);
x0=(Fast_Mul(x0,Mat[1][1])+Mat[1][0])%m%g;
printf("%lld\n",x0);
return 0;
}