PAT A1099. Build A Binary Search Tree (30)
- Build A Binary Search Tree (30)
时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format “left_index right_index”, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=102;
int flag[maxn]={1};
int In[maxn];
int cnt=0;
struct Node{
int data;
int l,r;
}node[maxn];
int n;
void LevelOrder(int root){
int ct=0;
queue<Node>q;
q.push(node[root]);
while(q.size()){
Node x=q.front();
printf("%d",x.data);
ct++;
if(ct<n)printf(" ");
q.pop();
if(x.l!=-1){
q.push(node[x.l]);
}
if(x.r!=-1){
q.push(node[x.r]);
}
}
}
void create(int root){
if(root==-1)return;
create(node[root].l);
node[root].data=In[cnt++];
create(node[root].r);
}
int main(){
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d %d",&node[i].l,&node[i].r);
if(node[i].l!=-1)flag[node[i].l]=0;
if(node[i].r!=-1)flag[node[i].r]=0;
}
int root=-1;
for(int i=0;i<n;i++){
if(flag[i]==1){
root=i;
break;
}
}
for(int i=0;i<n;i++)
scanf("%d",In+i);
sort(In,In+n);
create(root);
LevelOrder(root);
return 0;
}
上一篇: NYOJ 一笔画问题(DFS+欧拉回路)
下一篇: 孩子变声期 妈妈要准备好营养餐
推荐阅读
-
PAT甲级 1151 LCA in a Binary Tree (30分) 最近公共祖先
-
PAT A1099:Build A Binary Search Tree之中序遍历建树
-
LCA算法实际应用 PAT (Advanced Level) Practice 1151 LCA in a Binary Tree (30分) 四种方法完成题目+tarjan详细讲解!
-
1099 Build A Binary Search Tree
-
1099 Build A Binary Search Tree
-
1099 Build A Binary Search Tree
-
PAT 1099 Build A Binary Search Tree
-
【PAT】A1099. Build A Binary Search Tree (30)
-
PAT A1099. Build A Binary Search Tree (30)
-
1099 Build A Binary Search Tree