1099 Build A Binary Search Tree
1099 Build A Binary Search Tree (30 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index
, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int n;
struct Node
{
int val,l,r;
}node[101];
int a[101],id=0;
void in(int root)
{
if(root==-1)
return;
in(node[root].l);
node[root].val=a[id++];
in(node[root].r);
}
vector<int> ans;
void level(int root)
{
queue<int> q;
q.push(root);
while(q.size()!=0)
{
int front=q.front();
ans.push_back(node[front].val);
q.pop();
if(node[front].l!=-1)
q.push(node[front].l);
if(node[front].r!=-1)
q.push(node[front].r);
}
}
int main()
{
cin>>n;
for(int i=0;i<n;i++)
{
cin>>node[i].l>>node[i].r;
}
for(int i=0;i<n;i++)
cin>>a[i];
sort(a,a+n);
in(0);
level(0);
cout<<ans[0];
for(int i=1;i<ans.size();i++)
cout<<" "<<ans[i];
cout<<endl;
return 0;
}
推荐阅读
-
Convert Sorted Array to Binary Search Tree
-
【leetcode】-700. Search in a Binary Search Tree 查找二叉搜索树
-
Leetcode——108. Convert Sorted Array to Binary Search Tree
-
Leetcode 108. Convert Sorted Array to Binary Search Tree
-
LeetCode 235--二叉搜索树的最近公共祖先 ( Lowest Common Ancestor of a Binary Search Tree ) ( C语言版 )
-
LeetCode 235. Lowest Common Ancestor of a Binary Search Tree 二叉搜索树
-
235. Lowest Common Ancestor of a Binary Search Tree
-
235. Lowest Common Ancestor of a Binary Search Tree
-
[Leetcode] 235. Lowest Common Ancestor of a Binary Search Tree
-
leetcode 235. Lowest Common Ancestor of a Binary Search Tree(二叉树的最低共同祖先)