【PAT】A1099. Build A Binary Search Tree (30)
1099. Build A Binary Search Tree (30)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format “left_index right_index”, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int n, data[maxn], left, right, index = 0;
vector<int> vnode[maxn], result;
typedef struct node{
int data, right, left;
}node;
node nodes[maxn];
void inorder(int root){
if (nodes[root].left != -1)
inorder(nodes[root].left);
nodes[root].data = data[index++];
if (nodes[root].right != -1)
inorder(nodes[root].right);
}
void levelorder(int root){
queue<int> qi;
qi.push(root);
while (!qi.empty()){
int now = qi.front();
qi.pop();
result.push_back(nodes[now].data);
if (nodes[now].left != -1) qi.push(nodes[now].left);
if (nodes[now].right != -1) qi.push(nodes[now].right);
}
}
int main(){
scanf("%d", &n);
for (int i = 0; i < n; i++){
scanf("%d %d", &left, &right);
nodes[i].left = left;
nodes[i].right = right;
}
for (int i = 0; i < n; i++)
scanf("%d", &data[i]);
sort(data, data + n);
inorder(0);
levelorder(0);
for (int i = 0; i < n; i++){
if (i) printf(" ");
printf("%d", result[i]);
}
printf("\n");
system("pause");
return 0;
}
推荐阅读
-
PAT甲级 1151 LCA in a Binary Tree (30分) 最近公共祖先
-
PAT A1099:Build A Binary Search Tree之中序遍历建树
-
LCA算法实际应用 PAT (Advanced Level) Practice 1151 LCA in a Binary Tree (30分) 四种方法完成题目+tarjan详细讲解!
-
1099 Build A Binary Search Tree
-
1099 Build A Binary Search Tree
-
1099 Build A Binary Search Tree
-
PAT 1099 Build A Binary Search Tree
-
【PAT】A1099. Build A Binary Search Tree (30)
-
PAT A1099. Build A Binary Search Tree (30)
-
1099 Build A Binary Search Tree