迷宫问题(广搜 POJ 3984)
程序员文章站
2022-05-20 22:52:51
...
迷宫问题
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 33792 | Accepted: 19239 |
Description
定义一个二维数组:
int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, };
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0 0 1 0 1 0 0 0 0 0 0 0 1 1 1 0 0 0 0 1 0
Sample Output
(0, 0) (1, 0) (2, 0) (2, 1) (2, 2) (2, 3) (2, 4) (3, 4) (4, 4)
1.思路:常规做法。
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int num[6][6];
int vis[6][6];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
struct maze
{
int x;
int y;
};
queue<maze>q;
int judge(int x,int y)
{
if(x<0||x>4||y<0||y>4||num[x][y]!=0)
return 0;
if(vis[x][y]!=-1)
return 0;
return 1;
}
void out(int x,int y)
{
if(x==0&&y==0)
{
printf("(0, 0)\n");
return ;
}
else if(vis[x][y]==0)
out(x,y-1);
else if(vis[x][y]==1)
out(x,y+1);
else if(vis[x][y]==2)
out(x-1,y);
if(vis[x][y]==3)
out(x+1,y);
printf("(%d, %d)\n",x,y);
}
void bfs(int x,int y)
{
queue<maze>q;
maze first;
maze second;
first.x=0;
first.y=0;
vis[x][y]=1;
q.push(first);
while(!q.empty())
{
first=q.front();
q.pop();
if(first.x==4&&first.y==4)
{
out(first.x,first.y);
return ;
}
else
{
for(int i=0;i<4;i++)
{
second.x=first.x+dir[i][0];
second.y=first.y+dir[i][1];
if(judge(second.x,second.y))
{
vis[second.x][second.y]=i;
q.push(second);
}
}
}
}
}
int main()
{
for(int i=0;i<5;i++)
{
for(int j=0;j<5;j++)
{
cin>>num[i][j];
}
}
memset(vis,-1,sizeof(vis));
bfs(0,0);
return 0;
}