欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

北航:2018年计算机学院研究生推免机试第一题

程序员文章站 2022-05-15 14:08:06
...
同时也是PAT甲级1024
1024 Palindromic Number (25)(25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10^) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
/*北航计算机学院2018年夏令营推免上机考试第一题*/
/*同时也是PAT甲级考试1024*/
/*真的很难,对字符串、模拟问题需要特别熟练,包括大整数运算等*/
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;

static char s1[100];//数的范围在10^9以内,100应该是够了
static char s2[100];

int is_huiwen(char s[],int n)//判断该串是否是回文串
{
    int f=1;
    for(int i=0;i<n/2;i++)
        if(s[i]!=s[n-1-i])
        {
            f=0;
            break;
        }
    return f;
}

int main()
{
    int k,ck;
    int i,j,u,ii;
    while(~scanf("%s%d",s1,&k))
    {
        int cn=0;//cn用于记录步骤数
        int flag=0;//flag用于判断是否已在k步之内完成
        for(ii=0;ii<k;ii++)//注意这里的循环变量是ii,因为循环里面也有i所以这里不能是i,很容易错而且不容易发现
        {
            int len=strlen(s1);//取长度
            if(is_huiwen(s1,len))//一进来先判断是不是回文,如果是输出然后退出for循环
            {
                cout<<s1<<endl;
                cout<<cn<<endl;
                flag=1;
                break;
            }
            cn++;//不然,就说明肯定要进行后续步骤,那么cn++,说明步骤加一
            /*注意,下面要进行的是大整数加法,要从个位开始加,因此是逆过来的方便从个位开始相加,因此现在的s1实际上是s1的逆,我将s1反过来,其实才是真正的s1*/
            /*s1倒过来,存入s2*/
            for(u=0,j=len-1;j>=0;u++,j--)
                s2[u]=s1[j];
            s2[u]='\0';
            /*大整数加法,s1+s2*/
            ck=0;//ck是进位
            for(i=0;i<len;i++)//一位一位地加
            {
                int r=s1[i]-'0'+s2[i]-'0'+ck;
                s1[i]=r%10+'0';
                ck=r/10;
            }
            if(ck)//加完之后要判断一下最高位有没有进位,如果有就填上,没有就倒退一格
                s1[i]=ck+'0';
            else
                i--;
            s1[++i]='\0';//最后在下一格填上'\0'
            for(int w=0;w<i/2;w++)//现在求得的s1,其实是相加后的逆序,为了求得真正相加之后的数,需要逆序一下
            {
                char t;
                t=s1[w];
                s1[w]=s1[i-w-1];
                s1[i-1-w]=t;
            }
        }//for循环结束
        if(flag==1)//如果flag为1说明是break退出来的,说明早就输出结束了,直接continue吧
            continue;
        if(ii>=k)//注意哦,这里的循环变量是ii不是i,再次强调!!!ii>=k说明k步之后仍然不是回文,那么就直接输出吧
        {
            cout<<s1<<endl;
            cout<<k<<endl;
            continue;
        }
    }
}
北航:2018年计算机学院研究生推免机试第一题
相关标签: 模拟 字符串