C - How do you add
Larry is very bad at math — he usually uses a calculator, which worked well throughout college. Unforunately, he is now struck in a deserted island with his good buddy Ryan after a snowboarding accident. They’re now trying to spend some time figuring out some good problems, and Ryan will eat Larry if he cannot answer, so his fate is up to you! It’s a very simple problem — given a number N, how many ways can K numbers less than N add up to N? For example, for N = 20 and K = 2, there are 21 ways: 0+20 1+19 2+18 3+17 4+16 5+15 ... 18+2 19+1 20+0
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100, inclusive. The input will terminate on 2 0’s.
Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K, print a single number mod 1,000,000 on a single line.
Sample Input
20 2 20 2 0 0
Sample Output
21 21
https://www.cnblogs.com/pixiuart/p/5976817.html
上面可以复习高中相关知识
#include<bits/stdc++.h>
using namespace std;
const int n=210;
const int remain=1000000;
int a[n+1][n+1];
int initialize()
{
a[0][0]=1;
for(int i=1;i<=n;i++)
{
a[i][0]=1;
for(int j=1;j<n;j++)
{
a[i][j]=(a[i-1][j]%remain+a[i-1][j-1]%remain)%remain;
}
a[i][n]=1;
}
return 0;
}
int main()
{
int m,k;
initialize();
while(cin>>m>>k&&(m||k))
{
cout<<a[m+k-1][k-1]<<endl;
}
return 0;
}
这道题一开始我是没怎么看懂题目。我想的是相当于相同的1放在不同的盒子里,可以为空,但是后来想错了,先放一个1在每个n 的1里,保证不为0,但是不是清晰的分组了。只有组数确定的情况下,才可以这样做。
由于可以为0,相当于两个个板子中间没东西,就想到直接选元素,可相邻,可分开,于是放进原来n个元素。变成n+k-1个元素,选择k-1个即可。找的是共同具有的性质,再抽象转化。
上一篇: C - How do you add?
下一篇: How do you add it?
推荐阅读
-
How do I add a simple onClick event handler to a canvas element?
-
Redis in python, how do you close the connection?
-
How do you create different variable names while in a loop?
-
[转]How do you create a custom AuthorizeAttribute in ASP.NET Core?
-
How do you run an interactive process in Dart?
-
C - How do you add?
-
C - How do you add
-
How do you add it?
-
How do you check if a variable is an array in JavaScript? [duplicate]
-
Python,how do you work